summaryrefslogtreecommitdiff
path: root/dev-python/dugong/dugong-3.7.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dugong/dugong-3.7.3.ebuild')
-rw-r--r--dev-python/dugong/dugong-3.7.3.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/dugong/dugong-3.7.3.ebuild b/dev-python/dugong/dugong-3.7.3.ebuild
deleted file mode 100644
index e0c89a1e4cf9..000000000000
--- a/dev-python/dugong/dugong-3.7.3.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library for communicating with HTTP 1.1 servers"
-HOMEPAGE="https://github.com/python-dugong/python-dugong/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- || (
- dev-python/pytest-catchlog[${PYTHON_USEDEP}]
- >=dev-python/pytest-3.3.0[${PYTHON_USEDEP}]
- )
- )"
-
-python_test() {
- py.test -v || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/html/. )
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}