summaryrefslogtreecommitdiff
path: root/dev-python/dugong/dugong-3.7.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dugong/dugong-3.7.3.ebuild')
-rw-r--r--dev-python/dugong/dugong-3.7.3.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-python/dugong/dugong-3.7.3.ebuild b/dev-python/dugong/dugong-3.7.3.ebuild
deleted file mode 100644
index e1144b98f8bd..000000000000
--- a/dev-python/dugong/dugong-3.7.3.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library for communicating with HTTP 1.1 servers"
-HOMEPAGE="https://bitbucket.org/nikratio/python-dugong/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-catchlog[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- py.test -v || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/html/. )
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}