summaryrefslogtreecommitdiff
path: root/dev-python/doit
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/doit')
-rw-r--r--dev-python/doit/Manifest2
-rw-r--r--dev-python/doit/doit-0.32.0.ebuild70
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/doit/Manifest b/dev-python/doit/Manifest
index ab403bfee1bd..687398f1c1b7 100644
--- a/dev-python/doit/Manifest
+++ b/dev-python/doit/Manifest
@@ -1,3 +1,5 @@
DIST doit-0.29.0.tar.gz 222341 BLAKE2B 8489568fe9236af04f87debfb4889840aa162d17d20f82ac0a9a22d1034b4c58976cd6829486a15b941ac1f50e7137c052fe332657c2b3f529fe2345bbcba2fc SHA512 a686457df31b414d0c3797789e0ae1ae5cdfa3674025236419cb59b254f342cd2db07911ef18b2cb576d8d817b44035b9372265b34b786b2779fb7074b394de1
+DIST doit-0.32.0.tar.gz 1437939 BLAKE2B 39134341582cd964630a1667c78b0e44eeb32406a06e3567123b820fb61cbee0f6a7c8879a84eed750860a365aa4c792e461bb1534c66e4f20a6289522dc8183 SHA512 d5c28a0c6a38648aeef58027b2246fc26360e133e91933f2244bd484f70d6d26110acbfec19c74d53c796e0bbae07a4bf6d76542d45e8b1a6b503c186bf2a68a
EBUILD doit-0.29.0.ebuild 1950 BLAKE2B 11b8fdb08c8e092251fae2d8de516efcbd5bb8a78f6992e201deece848bbd3adaddb2ce97e69926e4487844576e298b84e156fb14203bd58794e1705ba4eaaa2 SHA512 85d5a9e5fe49dd8c266a161636037bfacf1195cd9e7ce775b2edcdad8daa1481c3eb5ab3bc419ec8ef5231a25c1a797937dc4cce1d7d5655e73714af5609ed77
+EBUILD doit-0.32.0.ebuild 1901 BLAKE2B 171089ce82492afd2a81d9d95b050887eb928d94810e19e608ed4eedea5d3c2e2b61dfde843d06275f6790201d29190e0547e32837b84cbfa35529c7cbab300c SHA512 96ecc9016ff76b797b9c18c5421d25bedc0d1603b651a394e37f5c86534cecdfbe595156a78b8cd9d04bbcafe07fab47f39074cd3bd76d29f72af062d73d61d6
MISC metadata.xml 295 BLAKE2B 3613e0bcfa3a5b2d21fa4eeaf8eb44475f01a98462879581f558f1c7c9cf9ea9a8b39bcfbf0ded02f964d7d4060726c1bc4dc622ea19cf75b35afd1e1560a408 SHA512 67b65f9a4adc57efe3c9846e3088737b28b74d80025bf2647aac3becf7cf542f0dee0f32e4a5d05299c768a8eb65729373fbe4af2c72ab073df1f43040b0c393
diff --git a/dev-python/doit/doit-0.32.0.ebuild b/dev-python/doit/doit-0.32.0.ebuild
new file mode 100644
index 000000000000..66a6cbdfb34a
--- /dev/null
+++ b/dev-python/doit/doit-0.32.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_6 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit eutils distutils-r1
+
+DESCRIPTION="Automation tool"
+HOMEPAGE="http://python-doit.sourceforge.net/ https://pypi.org/project/doit/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ dev-python/pyinotify[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/configparser[${PYTHON_USEDEP}]' python2_7 pypy)
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}] )
+"
+PDEPEND=">=dev-python/doit-py-0.3.0[${PYTHON_USEDEP}]"
+
+# Required for test phase
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ # Disable test failing due to impact on PATH run in a sandbox
+ sed -e s':test_target:_&:' -i tests/test_cmd_strace.py || die
+
+ # Test requires connection to an absent database
+ sed -e s':testIgnoreAll:_&:' -i tests/test_cmd_ignore.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ local -x TMPDIR="${T}"
+ # disable tests where pypy's treatment of some tests' use of a db is incompatible
+
+ if [[ "${EPYTHON}" == pypy ]]; then
+ sed -e 's:test_remove_all:_&:' -i tests/test_dependency.py || die
+ sed -e 's:testForgetAll:_&:' -i tests/test_cmd_forget.py || die
+ sed -e 's:test_not_picklable:_&:' \
+ -e 's:test_task_not_picklabe_multiprocess:_&:' \
+ -i tests/test_runner.py || die
+ fi
+
+ py.test || die "Tests failed under ${EPYTHON}"
+}
+
+src_install() {
+ use doc && HTML_DOCS=( doc/_build/html/. )
+
+ distutils-r1_src_install
+}