summaryrefslogtreecommitdiff
path: root/dev-python/docker-py/docker-py-3.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/docker-py/docker-py-3.3.0.ebuild')
-rw-r--r--dev-python/docker-py/docker-py-3.3.0.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/docker-py/docker-py-3.3.0.ebuild b/dev-python/docker-py/docker-py-3.3.0.ebuild
deleted file mode 100644
index 8ce9ced05031..000000000000
--- a/dev-python/docker-py/docker-py-3.3.0.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python client for Docker"
-HOMEPAGE="https://github.com/docker/docker-py"
-SRC_URI="https://github.com/docker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="doc test"
-
-RDEPEND="
- >=dev-python/docker-pycreds-0.2.3[${PYTHON_USEDEP}]
- !~dev-python/requests-2.18.0[${PYTHON_USEDEP}]
- >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
- >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' 'python3_4' )
- $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- >=dev-python/pytest-2.9.1[${PYTHON_USEDEP}]
- )
- doc? (
- dev-python/recommonmark[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.4.6[${PYTHON_USEDEP}]
- )
-"
-
-python_compile_all() {
- if use doc; then
- sphinx-build docs html || die "docs failed to build"
- HTML_DOCS=( html/. )
- fi
-}
-
-python_test() {
- py.test tests/unit/ || die "tests failed under ${EPYTHON}"
-}