summaryrefslogtreecommitdiff
path: root/dev-python/doc8
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/doc8')
-rw-r--r--dev-python/doc8/Manifest4
-rw-r--r--dev-python/doc8/doc8-1.1.1.ebuild34
-rw-r--r--dev-python/doc8/metadata.xml1
3 files changed, 38 insertions, 1 deletions
diff --git a/dev-python/doc8/Manifest b/dev-python/doc8/Manifest
index 12d139941425..70a6f86afb77 100644
--- a/dev-python/doc8/Manifest
+++ b/dev-python/doc8/Manifest
@@ -1,3 +1,5 @@
DIST doc8-1.0.0.tar.gz 26058 BLAKE2B 0113a4738804a9ed0446ae26b18f0f7da9dd3c4a90c598e03c78d3124f5db42dbc38f1f17af05ef60cb645a8b18bcb20aeb2f5cc00c44814afd572d92b2d0301 SHA512 98ad904a994536de80d6e89a221e3d7159d5188a0f57d07961f646e0591f81790f06c624ef90c32e28ff89ecf9e39b2b052363995aaece6a4e30f643c37964b9
+DIST doc8-1.1.1.tar.gz 26514 BLAKE2B 847e34081f4e00698cbe3ca9b7325de2995c45bd02b2f443459050a2801a5b476222c345c4ba06463fc6ff489c3c59e5b6e7abbd7b98af740f09d5b04771a4b2 SHA512 7ec21c2483f7ebf2a7e1fef6677c6051ac253da6014354a968b8a107d8097f986b6b162850561fd6a103e93d157b2c849554aabe2484a49c4a3726c8e2083a89
EBUILD doc8-1.0.0.ebuild 832 BLAKE2B b08861a20be43f2ff1164e4b0c74f58abdc30308de47d84d20d6f6ad845110f0e720731d1b18872b8889328b2ca619615258707db797daed6388d1dd2c0038b4 SHA512 3084ec1911d0852a2191e4a09aa13108f218aa441299eb7a9abc07427b951b4ddab069b1b51007dad4b44d5e3da899809bc3505ae876f0cbcf294403ea302868
-MISC metadata.xml 447 BLAKE2B 8be26ccdf9fd1e34e05eccee3abb8182d95438b7eb0f6dda03757e1d4a0f2b1c34861f81b9e8bbbb6634f141dc7867ecdf83022b05df6abe322716d78eafc9a4 SHA512 824cb036e31a498764941d78ebd744d2edaa2cd7a3282dbd5f2c16cbcb0adab12a80b0200528c40e01fc6dde851d1abed5b3d5fc2b27577a02cdfad5fa90663d
+EBUILD doc8-1.1.1.ebuild 841 BLAKE2B b911e77fe8773c10e4613d162da01a8a6d258e0ea21b9ca66bc2477d8cf2ad1b5bdf1952c15d598deb2b5fa2e4896acee4431192b8bcc701b48edb11784d3236 SHA512 e41c12fa62f4dd9f15d3d1ae5e3d4ee9b3e041e8390851c03d799908e957d7cf2738c3278335e05768d9473b253581549a72a482c1e200b3cd7ab196d0b9461a
+MISC metadata.xml 497 BLAKE2B 6e5c2f8a487d967892a471d045fcb0acfb2c4681375c352837820237110cfc8ea193c395730552cadeb09ca66316e91e99785aae821a184c619b32d7d8908b47 SHA512 a626b4ecc4cb4cdd2e0a095a2a26a3d0346e4c47608188fd6138517631d99a0f4c2e5ae8be453ac709dd43c2e4acc79b0ec7f37dd6e00125ebe23c99697658d0
diff --git a/dev-python/doc8/doc8-1.1.1.ebuild b/dev-python/doc8/doc8-1.1.1.ebuild
new file mode 100644
index 000000000000..f8c054851484
--- /dev/null
+++ b/dev-python/doc8/doc8-1.1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Style checker for Sphinx (or other) RST documentation"
+HOMEPAGE="
+ https://pypi.org/project/doc8/
+ https://github.com/PyCQA/doc8/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/docutils-0.21[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/restructuredtext-lint-0.7[${PYTHON_USEDEP}]
+ dev-python/stevedore[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+"
+# setuptools_scm_git_archive is not actually needed here
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/doc8/metadata.xml b/dev-python/doc8/metadata.xml
index 408cd2180853..3f2228a46d56 100644
--- a/dev-python/doc8/metadata.xml
+++ b/dev-python/doc8/metadata.xml
@@ -11,6 +11,7 @@
</maintainer>
<stabilize-allarches/>
<upstream>
+ <remote-id type="github">PyCQA/doc8</remote-id>
<remote-id type="pypi">doc8</remote-id>
</upstream>
</pkgmetadata>