summaryrefslogtreecommitdiff
path: root/dev-python/dns-lexicon
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dns-lexicon')
-rw-r--r--dev-python/dns-lexicon/Manifest2
-rw-r--r--dev-python/dns-lexicon/dns-lexicon-3.8.0.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/dns-lexicon/Manifest b/dev-python/dns-lexicon/Manifest
index 01fba800bfb3..874da92b211e 100644
--- a/dev-python/dns-lexicon/Manifest
+++ b/dev-python/dns-lexicon/Manifest
@@ -1,5 +1,7 @@
DIST dns-lexicon-3.3.4.tar.gz 147008 BLAKE2B 14e0bbba48b8340ecb274c122363aef6490de539ea2c1ce7a4ba4ef19eaa69271ea22e28afd700dba0a1060b01211f8ac9a1081e21973f07abb9ca057638241c SHA512 274a1a4ffd1d767623723b6e9aee1e9f07022f3985cbc15f75cc410f477e1dcb7a674fa847119bdccab7332d058f77ef85771bd7bcdadbe2dd9483415a365a6d
DIST dns-lexicon-3.7.0.tar.gz 7826689 BLAKE2B 920bfcd51642c12a0353dbc0ef8476c0def0c1fcf160757ce8ec47ce3516c1a2b203d2e07ef023b502b9a4e52d2fe91e9c0a73fa83337471e7669effc054a441 SHA512 aabfb2460bc2665b57552e6267846a0f2e508661dfdefbd22adca5833f32e8034198d1c3d5c33b2b89fb4a0cf0e9a84ec7d90426a6d8ba78acf2f2d0748c2d65
+DIST dns-lexicon-3.8.0.tar.gz 7830220 BLAKE2B 3e4e2bb6cc557ff75a87e4f32c0e04dc51cdc5552e8c7e0a47e5927a250ff5b564369285e6699b31021a97ac86fe90a42bbfac310c310f97ff2f9499351d6988 SHA512 a730852550eefd3461fd07c441cea65add2f6c0757a09c7f868da4ccdcd7cd2f1cdca96a652d11eeadab5e6dadceaba1dafc5b1d753efc6c6ec7a2fa2a5f342a
EBUILD dns-lexicon-3.3.4.ebuild 625 BLAKE2B 723c37b38fad26079e87f13fc99833f2f33af22682eb8b25b3f9e4d83c40c8aa1fd312f133e11b15f9c8921c125b599dcbe6bb397e90fa932934c8939d93e2e9 SHA512 0cd5aeff362c83f2ef711ac72dfaed3ffa6ac0488d31e9ec8a4dad8d725d24b4706dee9f1306832174d10266557ec2f873e99b90cbdf620cb609535cbfa3439c
EBUILD dns-lexicon-3.7.0.ebuild 1615 BLAKE2B c21607e29675f5336dd780a7e477851619a0a6c0a4545eb9156273b6ebb0a6bf062f163980a8f10b14ae3567c2fc5f72eb796962978fbcffa73b4256e0d25ae0 SHA512 75c759d184a933ccb7e06fee971a968dc115272a76abe7b6742bf5d4af926a6377b0c9bfd2dfb3170446bd8101468398b2db212e5af0958596e5909ba2ce801e
+EBUILD dns-lexicon-3.8.0.ebuild 1614 BLAKE2B e4491c94ba6fcd657c124325374c1adf65ed6fd14ffff2362335c9c3821fc640c18454bbc7d817930e6aff2cdb0a43fcfef80685b95ce471b6dc3abb0135ba1e SHA512 ce2f6bb1dd6bdfc1636efc74d98e910364f804f2e7a13955138a0f07bd7aac50ada97ea66bd862cbb93fc1882a3b4bfcc9ed4fc03675588cb44253154413685d
MISC metadata.xml 541 BLAKE2B a22266eac0bc7b4c22d9552cf64cbf88bbc1c2953e3ef0daaf059b81519909e0f8808e0d74cec6db3296e43f98082d57b8ae3779d694432e8578112ac18c3ea6 SHA512 79e2b43a685bfcc8dace1faa1c1a08cc648b39a3fef2834a57b6e801f72e7309276604253089db7a2fbe1d5d776b2ba1427c90a9cb9c44a0c1b2812d4e1901db
diff --git a/dev-python/dns-lexicon/dns-lexicon-3.8.0.ebuild b/dev-python/dns-lexicon/dns-lexicon-3.8.0.ebuild
new file mode 100644
index 000000000000..bf5ab2f7ce8d
--- /dev/null
+++ b/dev-python/dns-lexicon/dns-lexicon-3.8.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Manipulate DNS records on various DNS providers in a standardized/agnostic way"
+HOMEPAGE="https://pypi.org/project/dns-lexicon/"
+SRC_URI="https://github.com/AnalogJ/lexicon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/lexicon-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tldextract[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/zeep[${PYTHON_USEDEP}]
+ dev-python/vcrpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Requires the "localzone" module
+ lexicon/tests/providers/test_localzone.py
+ # Requires the "softlayer" module
+ lexicon/tests/providers/test_softlayer.py
+ # Requires the "transip" module
+ lexicon/tests/providers/test_transip.py
+ # Requires the "oci" module
+ lexicon/tests/providers/test_oci.py
+ # Uses tldextract which needs Internet access to download its database
+ lexicon/tests/providers/test_auto.py
+)
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ optfeature_header \
+ "Install the following packages to enable support for additional DNS providers:"
+ optfeature Gransy dev-python/zeep
+ optfeature Route53 dev-python/boto3
+ optfeature DDNS dev-python/dnspython
+ fi
+}