summaryrefslogtreecommitdiff
path: root/dev-python/dns-lexicon
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dns-lexicon')
-rw-r--r--dev-python/dns-lexicon/Manifest2
-rw-r--r--dev-python/dns-lexicon/dns-lexicon-3.20.1.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/dns-lexicon/Manifest b/dev-python/dns-lexicon/Manifest
index 4cbf51a49b6c..d02d4c4b47b2 100644
--- a/dev-python/dns-lexicon/Manifest
+++ b/dev-python/dns-lexicon/Manifest
@@ -1,5 +1,7 @@
DIST dns-lexicon-3.19.0.gh.tar.gz 6273456 BLAKE2B e0c47e8657b6c2724b50423359200cadac52434a31cbfd9c628ee5dd5cc3cd8779f4b51bb7522a308df90489f30aeec0a0ee44dcc850e5766d0f6b7d25b617f6 SHA512 4efc8864f073ca895a78eeedaf091f8b19df497caa9d8f759d051ac6e91c34e0798b0f7440cad601da62e4115a9abb596660255a8b02096959bd50411d5768be
DIST dns-lexicon-3.20.0.gh.tar.gz 6274333 BLAKE2B 98b9161b5eac26fcf41b7c3930a488f76a5be4a18303ab4fb13d66038b860d1ed7dc6d5e651630384aefa168bfe03ddba1be5da04e3d453be269b131d283d9b1 SHA512 80e1944687bed648ac70825ceb13098441d8937b362008f16a7eaebcc3c4a84ea15584ae5c6c31b88a08c503cfb5ed0e9f873192e6c0ba126dffd9b95576b681
+DIST dns-lexicon-3.20.1.gh.tar.gz 6275134 BLAKE2B 28d09b849891081f01150a25559625cbf2cfcccba5d8be36c8cb3ad5fa9c440a7d1b7f31a114edc5738ad337fba4cd520bbe85ce6753dfd9ca8855eb2aeab9e2 SHA512 98a29bc67596e58ada43373fd1dfa2a5c35512dd33924969df0d16c10cf2e53cf2bc564488c9f7a1b682b63a7959cd2073207a8d77435aa62a04f408024d85fd
EBUILD dns-lexicon-3.19.0.ebuild 1847 BLAKE2B 4a063e746d2fa613c606a3bc4f0fd574888de440ce1b8c7ad57e63d26de3cfe5b2c90df417e298dbba3dc8f237b451c0adfdc867526aa4517929e15a0bdca41d SHA512 bfb9c00c6ea5a7dcb796b6d9aab399d8e224ee1111fd8fc83386a12f82a7c66f162c876860a5d3c63f194a91ed64d5c48420128b99e5b04c8356fc655374269d
EBUILD dns-lexicon-3.20.0.ebuild 1889 BLAKE2B 77025fbd4dec035dee3779e2b7405d4d064a2083240f4b93bd7e7216e09b5f423a58fbba5837b1c4cc19dc3d7f8d98618b16ad700dd9c21a38b1b9fa19519323 SHA512 64b5399cd14dbfc848373eda1c3efad6ec0fd8abbb4bf88a7d3e4415c9965aa185d211c4280c07b93e6cefb5e9a361452836063bdeccd1583a4d4cf86d2a4e31
+EBUILD dns-lexicon-3.20.1.ebuild 1889 BLAKE2B 77025fbd4dec035dee3779e2b7405d4d064a2083240f4b93bd7e7216e09b5f423a58fbba5837b1c4cc19dc3d7f8d98618b16ad700dd9c21a38b1b9fa19519323 SHA512 64b5399cd14dbfc848373eda1c3efad6ec0fd8abbb4bf88a7d3e4415c9965aa185d211c4280c07b93e6cefb5e9a361452836063bdeccd1583a4d4cf86d2a4e31
MISC metadata.xml 541 BLAKE2B a22266eac0bc7b4c22d9552cf64cbf88bbc1c2953e3ef0daaf059b81519909e0f8808e0d74cec6db3296e43f98082d57b8ae3779d694432e8578112ac18c3ea6 SHA512 79e2b43a685bfcc8dace1faa1c1a08cc648b39a3fef2834a57b6e801f72e7309276604253089db7a2fbe1d5d776b2ba1427c90a9cb9c44a0c1b2812d4e1901db
diff --git a/dev-python/dns-lexicon/dns-lexicon-3.20.1.ebuild b/dev-python/dns-lexicon/dns-lexicon-3.20.1.ebuild
new file mode 100644
index 000000000000..f10b8737a4c9
--- /dev/null
+++ b/dev-python/dns-lexicon/dns-lexicon-3.20.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Manipulate DNS records on various DNS providers in a standardized/agnostic way"
+HOMEPAGE="
+ https://github.com/dns-lexicon/dns-lexicon/
+ https://pypi.org/project/dns-lexicon/
+"
+SRC_URI="
+ https://github.com/dns-lexicon/dns-lexicon/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/beautifulsoup4-4[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2[${PYTHON_USEDEP}]
+ >=dev-python/dnspython-2[${PYTHON_USEDEP}]
+ >=dev-python/pyotp-2[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3[${PYTHON_USEDEP}]
+ >=dev-python/requests-2[${PYTHON_USEDEP}]
+ >=dev-python/tldextract-2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/boto3-1.28[${PYTHON_USEDEP}]
+ >=dev-python/zeep-3[${PYTHON_USEDEP}]
+ dev-python/vcrpy[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # TODO
+ tests/test_client.py::test_client_init_when_missing_action_should_fail
+ tests/providers/test_godaddy.py::GoDaddyProviderTests
+)
+
+EPYTEST_IGNORE=(
+ # Requires the "localzone" module
+ tests/providers/test_localzone.py
+ # Requires the "softlayer" module
+ tests/providers/test_softlayer.py
+ # Requires the "transip" module
+ tests/providers/test_transip.py
+ # Requires the "oci" module
+ tests/providers/test_oci.py
+ # Uses tldextract which needs Internet access to download its database
+ tests/providers/test_auto.py
+)
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ optfeature_header \
+ "Install the following packages to enable support for additional DNS providers:"
+ optfeature Gransy dev-python/zeep
+ optfeature Route53 dev-python/boto3
+ optfeature DDNS dev-python/dnspython
+ fi
+}