summaryrefslogtreecommitdiff
path: root/dev-python/django-xslt
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django-xslt')
-rw-r--r--dev-python/django-xslt/Manifest4
-rw-r--r--dev-python/django-xslt/django-xslt-0.4.5-r1.ebuild35
-rw-r--r--dev-python/django-xslt/metadata.xml11
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/django-xslt/Manifest b/dev-python/django-xslt/Manifest
new file mode 100644
index 000000000000..dc51e6a2e4e3
--- /dev/null
+++ b/dev-python/django-xslt/Manifest
@@ -0,0 +1,4 @@
+DIST django-xslt-0.4.5.tar.gz 15717 BLAKE2B d150d105acc0834cda4f512f27a1a9cbdf7833585661e49d66761eee0fd5d00e45b292e04f602ed891a0ff0d7f1df303748194ca17cbc0e9bdd441671dc29a03 SHA512 25f3268d5eae29326ee93b5c4189389577bbf282e9f9007798de2ce96c6420d240c07e6a2abbbc57ce0bb4abb3aef557b545948a02b36a118afaefb30ca5a2b4
+DIST django-xslt-demoapp-0.4.5_p20120427.tar.bz2 5506 BLAKE2B 9a5d166fbe942747e48764d47ddce0c3b4a0efb3bc4220a1cca9f009da46356287ac03b719d5457ddf06e541212ef78bf99302b26a3c7b1adc26eb06100388d7 SHA512 200832172eac9c2729816c800fc32376ae62be2d832a398538054dca875fbedc41a300618f37f4d2b1cc36f36be20a6cbd86cc7f66e5ada476309e734c3f578d
+EBUILD django-xslt-0.4.5-r1.ebuild 924 BLAKE2B 08b0300b2fee84f9cf145dc9ee86627b35f9f848071e291c03ca2371e9bacd0c85abd5a415e039bf84f156e61e45d517ae233f34b83fa2f53fddf2c81b965c41 SHA512 b5d466dfa051a7970890fd5318ac17d4455241e32405655d5b9f277ce188a27327aab0fe3b00f9c65d36b6b17ba187cc5a38fe7ab22cd77dd02ee5d4e5f3a279
+MISC metadata.xml 324 BLAKE2B b6a558c019141968dfe52806211bf865f57e1bc3234da1e6a1af51f0fa6b99ca23e4cc8c16b0e486b322b4f1ea7ba25fba9993439e68308d2faa54b79dda6aa6 SHA512 aa9db49e681665d1d2ef3b1f2681985e0d12f7df1a8e731f966e7a426fe92a7901adbf3cc761d7885c553af8629d524a83a8dc2afea1bd24f55fe21e6601d047
diff --git a/dev-python/django-xslt/django-xslt-0.4.5-r1.ebuild b/dev-python/django-xslt/django-xslt-0.4.5-r1.ebuild
new file mode 100644
index 000000000000..b1b0ac06235c
--- /dev/null
+++ b/dev-python/django-xslt/django-xslt-0.4.5-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ test? ( https://dev.gentoo.org/~tampakrap/tarballs/${PN}-demoapp-0.4.5_p20120427.tar.bz2 )"
+
+DESCRIPTION="an XSLT template system for Django"
+HOMEPAGE="https://pypi.org/project/django-xslt/"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/lxml[${PYTHON_USEDEP}] )"
+
+python_test() {
+ export SECRET_KEY="green"
+ pushd "${WORKDIR}/demoapp" > /dev/null
+ if ! "${PYTHON}" -c "from django.conf import global_settings;global_settings.SECRET_KEY='$SECRET_KEY'" \
+ manage.py test; then
+ die "tests failed under ${EPYTHON}"
+ else
+ einfo "tests passed under ${EPYTHON}"
+ fi
+}
diff --git a/dev-python/django-xslt/metadata.xml b/dev-python/django-xslt/metadata.xml
new file mode 100644
index 000000000000..cd110bc1bcda
--- /dev/null
+++ b/dev-python/django-xslt/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">django-xslt</remote-id>
+ </upstream>
+</pkgmetadata>