summaryrefslogtreecommitdiff
path: root/dev-python/django-timezone-field/django-timezone-field-6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django-timezone-field/django-timezone-field-6.0.ebuild')
-rw-r--r--dev-python/django-timezone-field/django-timezone-field-6.0.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/django-timezone-field/django-timezone-field-6.0.ebuild b/dev-python/django-timezone-field/django-timezone-field-6.0.ebuild
deleted file mode 100644
index cc484c7ef9e9..000000000000
--- a/dev-python/django-timezone-field/django-timezone-field-6.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="A Django app providing database and form fields for timezone objects"
-HOMEPAGE="
- https://github.com/mfogel/django-timezone-field/
- https://pypi.org/project/django-timezone-field/
-"
-SRC_URI="
- https://github.com/mfogel/django-timezone-field/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- <dev-python/django-5[${PYTHON_USEDEP}]
- >=dev-python/django-2.2[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/djangorestframework[${PYTHON_USEDEP}]
- dev-python/pytest-django[${PYTHON_USEDEP}]
- dev-python/pytest-lazy-fixture[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local -x DB_ENGINE=sqlite
- epytest
-}