summaryrefslogtreecommitdiff
path: root/dev-python/django-prometheus
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django-prometheus')
-rw-r--r--dev-python/django-prometheus/Manifest4
-rw-r--r--dev-python/django-prometheus/django-prometheus-1.0.15.ebuild2
-rw-r--r--dev-python/django-prometheus/django-prometheus-1.1.0.ebuild18
3 files changed, 22 insertions, 2 deletions
diff --git a/dev-python/django-prometheus/Manifest b/dev-python/django-prometheus/Manifest
index 32597ea027f0..24b0da60a40c 100644
--- a/dev-python/django-prometheus/Manifest
+++ b/dev-python/django-prometheus/Manifest
@@ -1,3 +1,5 @@
DIST django-prometheus-1.0.15.tar.gz 13708 BLAKE2B 64d72224da9cb481108ad17ed1409d97108353a39894f824428743f3ee894292352de4d4beebf1984294e34cea7b6d0144c5066d0fe5cca7d9c682f9410355d3 SHA512 48794f6d07ebdd3487060e62e808a66a97630045433dd91a27f1095f79a72197124c44c5d178c89785b8d048e8e828f84804c789cb5c2f0a053cf18864cde6eb
-EBUILD django-prometheus-1.0.15.ebuild 478 BLAKE2B 5b17706f111c72c0417b2cf795f77a6ef34366fb349a2e668ebc921c25ae582884fd09d8e3f23713d1d67f087bda1576992288c6078ce1bef48477c9be6ac9c9 SHA512 8ea8adc6f8e1b2f950c7feb220c44493640fc5048b20c7ca52718fb54059ced42a383249963746b4d5222593a74d97e5841f1da383f5f3274d2eb7a5563b51b7
+DIST django-prometheus-1.1.0.tar.gz 18237 BLAKE2B 9b32e95750b57122a42d2e0b7f257407885a08db446e013933d2e81a525bf99f872f82c7f081f4c8c3c18f899c48ffa947ac8a89b751babaa8a8348f3f50b757 SHA512 9fa8c0175d1f8f714954f1c16715007e5c074568cc703d57e62f24686db1e16c40fc02244c4f9721995636723d90435bb3b2348282530d969b543bce39e65774
+EBUILD django-prometheus-1.0.15.ebuild 468 BLAKE2B db92e6d169ddbe99cb07d1ca014b8aa3b5e8c9c60abc3c6584a2176afa43cf73cae9732f4f21d73cbc70bb75b09eb6a8a8440a0becbf679d801790de44ede542 SHA512 3aa1c7b0bfaf09190c7af56337f44e77dd4ff605da3755c8fc6fad1736b859edb3fb6fde70467c707ddbf9aee7183ad75e4c1b4963742347904a5a9c7c389298
+EBUILD django-prometheus-1.1.0.ebuild 475 BLAKE2B 946e1559974b1f8059136c93413d40bc6f1bce2d00b64eb8217ae6331437130f1c77f8eb6977594c6a5db3e225f643d9612fa86a1b3bcd7e93eb3b50f2234e08 SHA512 1b1f86d553af8e87344fae0cf837a3b702609a0539588f47161a798f5d7d36abffaa5c09c1fc3b4b48629bc0987b3827b7ebacbdc55523d7214217c901b75494
MISC metadata.xml 248 BLAKE2B 5d9c3678c604aac0f24c5d5015e28f02b9ce83bb6a179755a44adeb3d69e4dd50be4acc30a6317649f5be23bcf13ac210bbe4712aa403e9c4cf2de351b39c941 SHA512 dc5b06a888be6367909895d5891a08189f4657bcee602e5ff0021be2ad3677e58ec7387ff244625be66a142138666e7eac790d2a7b1e298f0ad644725b5e57e0
diff --git a/dev-python/django-prometheus/django-prometheus-1.0.15.ebuild b/dev-python/django-prometheus/django-prometheus-1.0.15.ebuild
index fe4f69261888..9475961ac431 100644
--- a/dev-python/django-prometheus/django-prometheus-1.0.15.ebuild
+++ b/dev-python/django-prometheus/django-prometheus-1.0.15.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_6 )
+PYTHON_COMPAT=( python3_6 )
inherit distutils-r1
DESCRIPTION="Library to export django metrics for prometheus"
diff --git a/dev-python/django-prometheus/django-prometheus-1.1.0.ebuild b/dev-python/django-prometheus/django-prometheus-1.1.0.ebuild
new file mode 100644
index 000000000000..7ad6293b28e2
--- /dev/null
+++ b/dev-python/django-prometheus/django-prometheus-1.1.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 python3_7 )
+inherit distutils-r1
+
+DESCRIPTION="Library to export django metrics for prometheus"
+HOMEPAGE="https://github.com/korfuri/django-prometheus"
+SRC_URI="mirror://pypi/${PN:0:1}"/${PN}/${P}.tar.gz
+
+LICENSE="Apache-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=">=dev-python/prometheus_client-0.7[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"