summaryrefslogtreecommitdiff
path: root/dev-python/django-prometheus/django-prometheus-2.2.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django-prometheus/django-prometheus-2.2.0-r1.ebuild')
-rw-r--r--dev-python/django-prometheus/django-prometheus-2.2.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/django-prometheus/django-prometheus-2.2.0-r1.ebuild b/dev-python/django-prometheus/django-prometheus-2.2.0-r1.ebuild
new file mode 100644
index 000000000000..680ccac5129a
--- /dev/null
+++ b/dev-python/django-prometheus/django-prometheus-2.2.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Library to export Django metrics for Prometheus"
+HOMEPAGE="
+ https://github.com/korfuri/django-prometheus/
+ https://pypi.org/project/django-prometheus/
+"
+
+LICENSE="Apache-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+ >=dev-python/prometheus_client-0.7[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i "/pytest-runner/d" setup.py || die
+ distutils-r1_python_prepare_all
+}