summaryrefslogtreecommitdiff
path: root/dev-python/django-mptt/django-mptt-0.13.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django-mptt/django-mptt-0.13.ebuild')
-rw-r--r--dev-python/django-mptt/django-mptt-0.13.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/django-mptt/django-mptt-0.13.ebuild b/dev-python/django-mptt/django-mptt-0.13.ebuild
new file mode 100644
index 000000000000..584beed17861
--- /dev/null
+++ b/dev-python/django-mptt/django-mptt-0.13.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="utilities for modified preorder tree traversal and trees of model instances"
+HOMEPAGE="https://github.com/django-mptt/django-mptt"
+SRC_URI="
+ https://github.com/django-mptt/django-mptt/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/django-1.11[${PYTHON_USEDEP}]
+ dev-python/django-js-asset[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-test-install.patch
+)
+
+python_test() {
+ "${EPYTHON}" tests/manage.py test -v2 myapp ||
+ die "Tests failed with ${EPYTHON}"
+}