summaryrefslogtreecommitdiff
path: root/dev-python/dj-database-url/dj-database-url-2.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dj-database-url/dj-database-url-2.0.0.ebuild')
-rw-r--r--dev-python/dj-database-url/dj-database-url-2.0.0.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/dev-python/dj-database-url/dj-database-url-2.0.0.ebuild b/dev-python/dj-database-url/dj-database-url-2.0.0.ebuild
index 7c7f2279f539..4dfb018a6ed8 100644
--- a/dev-python/dj-database-url/dj-database-url-2.0.0.ebuild
+++ b/dev-python/dj-database-url/dj-database-url-2.0.0.ebuild
@@ -4,21 +4,16 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
PYTHON_COMPAT=( python3_{9..11} )
-inherit distutils-r1
+inherit distutils-r1 pypi
DESCRIPTION="Use Database URLs in your Django Application"
HOMEPAGE="
https://github.com/jazzband/dj-database-url/
https://pypi.org/project/dj-database-url/
"
-# tests are missing in sdist as of 1.3.0
-# https://github.com/jazzband/dj-database-url/pull/213
-SRC_URI="
- https://github.com/jazzband/dj-database-url/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
SLOT="0"
LICENSE="BSD"
@@ -30,3 +25,7 @@ RDEPEND="
"
distutils_enable_tests unittest
+
+python_test() {
+ eunittest -s tests
+}