summaryrefslogtreecommitdiff
path: root/dev-python/distro/distro-1.8.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/distro/distro-1.8.0.ebuild')
-rw-r--r--dev-python/distro/distro-1.8.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/distro/distro-1.8.0.ebuild b/dev-python/distro/distro-1.8.0.ebuild
new file mode 100644
index 000000000000..450a7bea04af
--- /dev/null
+++ b/dev-python/distro/distro-1.8.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Reliable machine-readable Linux distribution information for Python"
+HOMEPAGE="
+ https://distro.readthedocs.io/en/latest/
+ https://github.com/python-distro/distro/
+ https://pypi.org/project/distro/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests pytest