summaryrefslogtreecommitdiff
path: root/dev-python/diskcache
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/diskcache')
-rw-r--r--dev-python/diskcache/Manifest3
-rw-r--r--dev-python/diskcache/diskcache-5.2.1-r1.ebuild42
-rw-r--r--dev-python/diskcache/diskcache-5.2.1.ebuild6
3 files changed, 47 insertions, 4 deletions
diff --git a/dev-python/diskcache/Manifest b/dev-python/diskcache/Manifest
index 9441a6b714ea..7543f9c86180 100644
--- a/dev-python/diskcache/Manifest
+++ b/dev-python/diskcache/Manifest
@@ -1,3 +1,4 @@
DIST diskcache-5.2.1.gh.tar.gz 652769 BLAKE2B 25fcdcf51c8be7a6e2a9de645258f776647789a7f06c70c8564ad28bd003a745167095b11a54d435e733d9f5181a1443be2510fe2d901cc208ea426d3359c0ba SHA512 6e55bada12145d931f4a465092decc3f2cfed2e618d1ea271ad6daa6caf7c3abfd6ae5de11072efdf898ebf272acd39136136b58d7b5e735092963bdd46af52e
-EBUILD diskcache-5.2.1.ebuild 833 BLAKE2B 32a4d49c98cd7074c90661572f1a6fff6af85b3bef6515f9d5ae00611491bc246b68c09eead1cc2dcf055b5f3d1ea8e20cebc5a1785dd011654bbce5a21b2a79 SHA512 84fc57af0cf59304851052d90499c6c57c4491c2dc125a04fcabbf634290bc17c0d974b4faa3e7a2963f5c6cd7fbe00a65126842799a556072e2fac6af807d3b
+EBUILD diskcache-5.2.1-r1.ebuild 1007 BLAKE2B 099c57ed08d4ecf517d305a231a2a66983f5b1bf66c43a56917e9e03904dc85b728b6ee3d4e78aac744dd87aa021c8ae18b72902cdef52a7e0bc35fda1562bd3 SHA512 8708fe09184a5a92cf49a1782f2940e32cb1960fcbb3b619a6800f35a947dda3e8e9a048d845fcc8471a1d386055ad4fd3e804b5edb9fa701ed5a536203aa149
+EBUILD diskcache-5.2.1.ebuild 845 BLAKE2B 9b435c3adf032acdc81a283d00102cb3f0b9dbe22f76438f02eb98b0234cbe0418af1526192f84409d6c4bb7a1b6baec07dcc0ac888002c808dbcc3913462fd8 SHA512 3525d0cefdfa839fd45bf337501a2a17c799eaada4edf79e9ce7a3d890282ba98036b5dbb3741e4a53d7afdb9f0d3e21ea17fb984bd1d084f9569180769c7b02
MISC metadata.xml 416 BLAKE2B abce0086d9e449bb58281c7856b518501d837b88473dcd611d3f7026a221bb320d866ba631f704a2cc9a5d24af88fdb171e5a0dc28a79f88852ce6931d4a37e7 SHA512 14c60bba29274523a81a24008d51d74ed2ff3c5ae84ed11110fd1e3b83c39c35eb0a95d56edf53db5bbccd08c6bea62cc3019405a077dc00a0869f01e6968c9e
diff --git a/dev-python/diskcache/diskcache-5.2.1-r1.ebuild b/dev-python/diskcache/diskcache-5.2.1-r1.ebuild
new file mode 100644
index 000000000000..362a97886afd
--- /dev/null
+++ b/dev-python/diskcache/diskcache-5.2.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+HOMEPAGE="http://www.grantjenks.com/docs/diskcache/
+ https://github.com/grantjenks/python-diskcache/"
+DESCRIPTION="Disk and file backed cache"
+SRC_URI="
+ https://github.com/grantjenks/python-diskcache/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+S=${WORKDIR}/python-diskcache-${PV}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+src_prepare() {
+ # remove dep on pytest-xdist and pytest-cov
+ sed -i -e '/-n auto/d' -e '/--cov/d' tox.ini || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local ignore=(
+ # django tests don't work with django-3.2, and django-3.1
+ # doesn't work with py3.10
+ tests/test_djangocache.py
+ tests/test_doctest.py
+ README.rst
+ )
+ epytest ${ignore[@]/#/--ignore }
+}
diff --git a/dev-python/diskcache/diskcache-5.2.1.ebuild b/dev-python/diskcache/diskcache-5.2.1.ebuild
index d944ac6dd64e..d5be692d8b69 100644
--- a/dev-python/diskcache/diskcache-5.2.1.ebuild
+++ b/dev-python/diskcache/diskcache-5.2.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..9} )
PYTHON_REQ_USE="sqlite"
inherit distutils-r1
@@ -18,11 +18,11 @@ S=${WORKDIR}/python-diskcache-${PV}
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="amd64 ~arm arm64 x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 ~arm arm64 ~mips ~ppc64 x86 ~amd64-linux ~x86-linux"
BDEPEND="
test? (
- >=dev-python/django-2.2[${PYTHON_USEDEP}]
+ <dev-python/django-3.2[${PYTHON_USEDEP}]
)
"