summaryrefslogtreecommitdiff
path: root/dev-python/discogs-client/discogs-client-2.3.12-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/discogs-client/discogs-client-2.3.12-r1.ebuild')
-rw-r--r--dev-python/discogs-client/discogs-client-2.3.12-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/discogs-client/discogs-client-2.3.12-r1.ebuild b/dev-python/discogs-client/discogs-client-2.3.12-r1.ebuild
new file mode 100644
index 000000000000..36b9175dec97
--- /dev/null
+++ b/dev-python/discogs-client/discogs-client-2.3.12-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/joalla/discogs_client.git"
+ inherit git-r3
+else
+ MY_PN='python3-discogs-client'
+ MY_P=${MY_PN}-${PV}
+ SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="Continuation of the official Python API client for Discogs"
+HOMEPAGE="https://github.com/joalla/discogs_client https://pypi.org/project/python3-discogs-client/"
+
+LICENSE="BSD-2"
+SLOT="0"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/oauthlib[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests nose