summaryrefslogtreecommitdiff
path: root/dev-python/discid
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/discid')
-rw-r--r--dev-python/discid/Manifest3
-rw-r--r--dev-python/discid/discid-1.2.0-r1.ebuild40
-rw-r--r--dev-python/discid/metadata.xml12
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/discid/Manifest b/dev-python/discid/Manifest
new file mode 100644
index 000000000000..917db0494be2
--- /dev/null
+++ b/dev-python/discid/Manifest
@@ -0,0 +1,3 @@
+DIST python-discid-1.2.0.gh.tar.gz 30756 BLAKE2B 616613de23b66adfc92227a9f36b710649f2a419ffd83443766ebcf1dbfaf528b7d933011bcbdcd19f5092726b81e40d905a62a64262a528dfad89e561210992 SHA512 239cb608508e94109aa9b8b582bc3de1fb9408b508d56698d7f17ec9ebb0d37c1fb76557d98b6d194c1532e3047efcde3adc5d6e9634bc87533d331423a7f19f
+EBUILD discid-1.2.0-r1.ebuild 807 BLAKE2B 46bcef21e2cfb2eacbc3d7385725c153752de8fb886a7624606dca4432b64a37db8653c1322b728786d60056e1ca860fdf38d093e4f16c32a789130ed0a75956 SHA512 38a87d8f2079ebf21c14087ff4c02122301e8cc5054229f86c57a388f4fea930a7de0957f1d507a117079490864baf989b1a92338d255ffe6bd1d89750071e7d
+MISC metadata.xml 371 BLAKE2B 4b7018e07405d1a136a9aac46dfca2de948cb3c332a683b2c28d5ca7eeb190e2f516490a9acd051a572179f1e24696498dba5d1ba482f500a0f5f9529783415c SHA512 1feae4778b19e5dd9bdde91c04dae4133b6a08808e06350d8a7e14181bd93950dbe2ba3a41da558bdce852088f036128f20c62aa0d4f1adaa26c3921b9658753
diff --git a/dev-python/discid/discid-1.2.0-r1.ebuild b/dev-python/discid/discid-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..540422f5c129
--- /dev/null
+++ b/dev-python/discid/discid-1.2.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=python-discid-${PV}
+DESCRIPTION="Python bindings for libdiscid"
+HOMEPAGE="
+ https://python-discid.readthedocs.io/en/latest/
+ https://github.com/JonnyJD/python-discid/
+ https://pypi.org/project/discid/
+"
+SRC_URI="
+ https://github.com/JonnyJD/python-discid/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~ppc x86"
+
+DEPEND="
+ >=media-libs/libdiscid-0.2.2
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+distutils_enable_sphinx doc
+
+python_test() {
+ "${EPYTHON}" -m unittest -v test_discid.TestModule{Private,} ||
+ die "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/discid/metadata.xml b/dev-python/discid/metadata.xml
new file mode 100644
index 000000000000..b7e9b9d92f87
--- /dev/null
+++ b/dev-python/discid/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">JonnyJD/python-discid</remote-id>
+ <remote-id type="pypi">discid</remote-id>
+ </upstream>
+</pkgmetadata>