summaryrefslogtreecommitdiff
path: root/dev-python/dirty-equals
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dirty-equals')
-rw-r--r--dev-python/dirty-equals/Manifest2
-rw-r--r--dev-python/dirty-equals/dirty-equals-0.7.1.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/dirty-equals/Manifest b/dev-python/dirty-equals/Manifest
index f9d0d27360f5..390734666d2e 100644
--- a/dev-python/dirty-equals/Manifest
+++ b/dev-python/dirty-equals/Manifest
@@ -1,3 +1,5 @@
DIST dirty-equals-0.6.0.gh.tar.gz 47114 BLAKE2B 910f09e5f5b2ec62d3b4d50ac23a17ee481875b9ae7303faf9bb610282113941b8a121d39e14e1a63cae0433055e639b1bc2da5c1fc3a9ece4915e34c172f40b SHA512 aff41b31c255294c2d6c3a3170daea56d98da4875f9ffdef96b522db24fbed92edf4618646b3e1b50680ce03fca1b9c2bb591730c397b85143ace846c513ac01
+DIST dirty-equals-0.7.1.gh.tar.gz 49000 BLAKE2B 06c9a7522f1dda95ff682dc9c28207b29754d11b4afe7eeacd5439a9ae9f34ce0a2f5724703129aa90b5577f36646deafa5428120e823502aae616d57b3d8f0d SHA512 c50a15e4cee77b3db1b07ef9f7d1eb5b3ab6bed6d914ac5c9e2982f8cf9432beaecb5fd7997d46a94f405e0c932ea5a8d72f1c1d4b6dda86161c22cc772ab4d7
EBUILD dirty-equals-0.6.0-r3.ebuild 1438 BLAKE2B d0c8b8dc6046b8ed14d843e31bbe812dad634f9791034f38cc394de9dc9ab5ce055bb6befff895c63ba55caed4d61bfc41c5adfba47ea5c8983bf46fc0a5b9b0 SHA512 37894700273abf784e808e9ee38c4bb348abe72fd8f2f7d1d118577fa1d24a3d04dd271adcb9150ecd853aaf496170e21abccc614d64b654507b1ef361208394
+EBUILD dirty-equals-0.7.1.ebuild 994 BLAKE2B 95fc0e886bf71713024a9503f48cb949934f295d255d1130b47ce156ca008948371a0dd2f677d430ee1f3af7a989ac8a11d05e40399bdff825b6e5b0ebb05a9c SHA512 eec6f4711fc3a0f6e01ae05692d569bdc2ffec70d6bdfc75b2f7df673e6576c5b31758cc2de4c6874c1bcad36e38dcda253daef487962ae33bee9ee52458eec1
MISC metadata.xml 359 BLAKE2B 120f82faf2460b2528927b708a41b2d105248a57af2f3f11966b102237731f9dab87962069728dd78327757c190790f01646c94c228d0e79bf60fbab82e1ca39 SHA512 fb17ee5e8483cd6c5ce840c2f070601c4506b0d62a8c6a80338e8748e57bfb49ee412faf7b95f21c16e5c5730efb9879d8d66fd4fd1c134ca459af3657994f98
diff --git a/dev-python/dirty-equals/dirty-equals-0.7.1.ebuild b/dev-python/dirty-equals/dirty-equals-0.7.1.ebuild
new file mode 100644
index 000000000000..e072dbd547a1
--- /dev/null
+++ b/dev-python/dirty-equals/dirty-equals-0.7.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Doing dirty (but extremely useful) things with equals"
+HOMEPAGE="
+ https://dirty-equals.helpmanual.io/
+ https://github.com/samuelcolvin/dirty-equals/
+ https://pypi.org/project/dirty-equals/
+"
+SRC_URI="
+ https://github.com/samuelcolvin/dirty-equals/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pytz-2021.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pydantic-2.4.2[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # require unpackaged pytest-examples
+ tests/test_docs.py
+ )
+
+ local -x TZ=UTC
+ epytest "${args[@]}"
+}