summaryrefslogtreecommitdiff
path: root/dev-python/dill
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dill')
-rw-r--r--dev-python/dill/Manifest3
-rw-r--r--dev-python/dill/dill-0.3.8-r1.ebuild (renamed from dev-python/dill/dill-0.3.8.ebuild)4
-rw-r--r--dev-python/dill/dill-0.3.8-r2.ebuild33
3 files changed, 39 insertions, 1 deletions
diff --git a/dev-python/dill/Manifest b/dev-python/dill/Manifest
index 0c926107aaba..a054c5bc7f79 100644
--- a/dev-python/dill/Manifest
+++ b/dev-python/dill/Manifest
@@ -1,3 +1,4 @@
DIST dill-0.3.8.tar.gz 184847 BLAKE2B 6a0eb76526d5bc4afa003f34454c3a93b2b53e2d5bd362749bfcc22c6fe294dff3af9d52e83b288e999d7074d82a2671b3d271b3b423030f4cfd57cd70acdc6f SHA512 478d83af69dc0639a08e011e46127d9485dc998df54622e7fbb9ce4b004640d1b23aad57717d791cc609cd9d7071ea7300bce4be982488e4d21c5986e67ce586
-EBUILD dill-0.3.8.ebuild 602 BLAKE2B 78ad2e7eb079272c74b8ac45d758f1f5bd47e83b8516d056d30a8b344a25e42c46f37679f98321572425d8b513de0066b4e2b0c19795849c6a844fa2ae44bb31 SHA512 87dcfbf03607027a29649586891d9a65edb6eec2174f47fcafacce76666f3fc90c4961a1c35883b147ab1503af50b57b8ac79100b12316af2d3aa5c375e11e9d
+EBUILD dill-0.3.8-r1.ebuild 657 BLAKE2B af8e4413ff72fbe0358e44e102be579288e46c6c692954faede91edb0daeab958031e43b305a31ca13f9b62bb1ef39ec7bc19bc8d4f83ece3c7d47b02dcc1462 SHA512 a6f538221d4b405bf0dada92b45a4a35579669f94faf2c3e7b3dcf34372bdcddf9a5e52da00a9404abe847b9609ed8aa1d02d7bb76fed372b496acfac3b144f2
+EBUILD dill-0.3.8-r2.ebuild 856 BLAKE2B 2a21a045cfd1edf2f549c7faab0beb20ea78e64a0f3899a8af79eb021fc68554a40fee0f6a4033f12a879e466823087a428a1910c736fa43c1c5e1f903ee0c54 SHA512 2dc6dd92bdc08a444dbab60d976fa1fec4e8610b01cf26c2baddbec31e590eef2c80fe3793a766e4f6ddc2ae81215c55ac779b2eae6047cea27bd1a7e223d946
MISC metadata.xml 997 BLAKE2B ae32cd96d7a4967a9886d4903e21720459c0a963a675d301c2bb651fdb15877d845100822c1e7a7b6184ccaa666cbb6dc58f939616de9c1c22554670d841bd19 SHA512 e3dc363382bea8ed76343b62377c139ad84011a6b804f64b65d93941a7c192c268c0da273c73d5ec1cece7320b15fa88bf5a2f20a628d8845efddab24f3acc5b
diff --git a/dev-python/dill/dill-0.3.8.ebuild b/dev-python/dill/dill-0.3.8-r1.ebuild
index 301fe58978d6..46438895e551 100644
--- a/dev-python/dill/dill-0.3.8.ebuild
+++ b/dev-python/dill/dill-0.3.8-r1.ebuild
@@ -19,6 +19,10 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
+RDEPEND="
+ !!>=dev-python/numpy-2[${PYTHON_USEDEP}]
+"
+
python_test() {
"${EPYTHON}" -m dill.tests || die
}
diff --git a/dev-python/dill/dill-0.3.8-r2.ebuild b/dev-python/dill/dill-0.3.8-r2.ebuild
new file mode 100644
index 000000000000..94ced8edf7b9
--- /dev/null
+++ b/dev-python/dill/dill-0.3.8-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Serialize all of Python (almost)"
+HOMEPAGE="
+ https://github.com/uqfoundation/dill/
+ https://pypi.org/project/dill/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # numpy support broken: https://github.com/uqfoundation/dill/issues/667
+ sed -i -e 's:import numpy:raise ImportError:' dill/__diff.py || die
+}
+
+python_test() {
+ # disables a test broken under Python 3.13
+ # https://github.com/uqfoundation/dill/issues/668
+ local -x COVERAGE=1
+ "${EPYTHON}" -m dill.tests || die
+}