summaryrefslogtreecommitdiff
path: root/dev-python/diff-cover/diff-cover-1.0.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/diff-cover/diff-cover-1.0.4.ebuild')
-rw-r--r--dev-python/diff-cover/diff-cover-1.0.4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/diff-cover/diff-cover-1.0.4.ebuild b/dev-python/diff-cover/diff-cover-1.0.4.ebuild
new file mode 100644
index 000000000000..dfca39bedb15
--- /dev/null
+++ b/dev-python/diff-cover/diff-cover-1.0.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically find diff lines that need test coverage"
+HOMEPAGE="https://github.com/Bachmann1234/diff-cover"
+SRC_URI="https://github.com/Bachmann1234/diff-cover/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.7.1[${PYTHON_USEDEP}]
+ dev-python/jinja2_pluralize[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ <dev-python/pycodestyle-2.4.0[${PYTHON_USEDEP}]
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ esetup.py test || die "tests failed with ${EPYTHON}"
+}