summaryrefslogtreecommitdiff
path: root/dev-python/dicttoxml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dicttoxml')
-rw-r--r--dev-python/dicttoxml/Manifest2
-rw-r--r--dev-python/dicttoxml/dicttoxml-1.7.4-r2.ebuild22
-rw-r--r--dev-python/dicttoxml/files/dicttoxml-1.7.4-py3.10.patch58
3 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/dicttoxml/Manifest b/dev-python/dicttoxml/Manifest
index 0a41ad5adf52..4f274a4f3d00 100644
--- a/dev-python/dicttoxml/Manifest
+++ b/dev-python/dicttoxml/Manifest
@@ -1,3 +1,5 @@
+AUX dicttoxml-1.7.4-py3.10.patch 2064 BLAKE2B 3cf7ba808fe4f0a74281f29dd120304ff1b69e39d1a8cfaac930297fdc801acb11f13903ce3806ba823968ff1df6c5493a4e2672c37c4bb385e806c624c5bece SHA512 8813bdbe353eb54087946aba4cb6bad7893ad1ca9b92b449d2298fe6e4e4ec6881f712ffe2eb42154c6ddfce37e6fef3f7a6949a792e148c330dac5f9d99383c
DIST dicttoxml-1.7.4.tar.gz 18190 BLAKE2B e8fd4974cbd9e83b72c25f28fa5595421be88ed5fbb1e64721280c4ead3003f95c98c7b4f12bced926f0c4af31b30dd76ddd49ddf297fa5f68eeb466d042ede6 SHA512 91abcf2b9b248717618e9fc1c8694e881b9deaa16438dd4674f94a22b4aabfdab3b13f95c3d44a60577d49eca82fb268f59b33d1312cf5388bdaf949a2865cbf
EBUILD dicttoxml-1.7.4-r1.ebuild 485 BLAKE2B c0e650f38e955b2aeeb7fc967836a109504962d2c471cef833e615bb7149f9309e1553ce19ac6ed0d7e4c51512e5264a212521acd18176b83589bb0b92007dc4 SHA512 5ac813ec429c7bcea6b43498c053bbf4a30f17c2deb663bf294911eaa8ff2633597722d79d0624225d5d9d6c027a1a616b0484544b313373c0a59deed4ccab6a
+EBUILD dicttoxml-1.7.4-r2.ebuild 596 BLAKE2B 81240c4fc242e115a395b9ca514a48f63d36105f19d6334e7097d256c0df9b97e92832e370120dd5cbfd967c5675c1754d4609655f626010e5c15090e52e79f3 SHA512 62a6903808755bda8896eaa6e3901b7f82663a5e62b2253b9cdb3341b81603eecdac79ddbe388651e2f6878fada61f843f806f51aaa56b73509e178d31ef6461
MISC metadata.xml 503 BLAKE2B 6669e69ea7d5afa8edb064e78652a4b035f19dd786aa8eb531ed2cbdc4274a884330e7159b9a3ed051a28a0be531237bc88fe893961e5b59fec738a6d902a0c9 SHA512 3bf0c6926f48f42ce8e81c3111a625f43d043af1a95fc74eeb2463f789a2226591cea81b5f1ec1f4c12bbf365f3002f5f652f2dc7ce0ae2bf26bee1eceef75b3
diff --git a/dev-python/dicttoxml/dicttoxml-1.7.4-r2.ebuild b/dev-python/dicttoxml/dicttoxml-1.7.4-r2.ebuild
new file mode 100644
index 000000000000..a6882bd19034
--- /dev/null
+++ b/dev-python/dicttoxml/dicttoxml-1.7.4-r2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="Converts a Python dictionary or other data type to a valid XML string"
+HOMEPAGE="https://github.com/quandyfactory/dicttoxml https://pypi.org/project/dicttoxml/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+PATCHES=(
+ # https://github.com/quandyfactory/dicttoxml/pull/73/files
+ "${FILESDIR}/${P}-py3.10.patch"
+)
diff --git a/dev-python/dicttoxml/files/dicttoxml-1.7.4-py3.10.patch b/dev-python/dicttoxml/files/dicttoxml-1.7.4-py3.10.patch
new file mode 100644
index 000000000000..5b3fe172949e
--- /dev/null
+++ b/dev-python/dicttoxml/files/dicttoxml-1.7.4-py3.10.patch
@@ -0,0 +1,58 @@
+From 2b7b4522b7255fbc8f1e04304d2e440d333909d5 Mon Sep 17 00:00:00 2001
+From: Kier von Konigslow <kvonkonigslow@gmail.com>
+Date: Sat, 28 Dec 2019 14:08:46 -0500
+Subject: [PATCH] Fix deprecation with collections abc
+
+---
+ dicttoxml.py | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/dicttoxml.py b/dicttoxml.py
+index ae1384a..5d2dd54 100755
+--- a/dicttoxml.py
++++ b/dicttoxml.py
+@@ -15,7 +15,7 @@
+ version = __version__
+
+ from random import randint
+-import collections
++import collections.abc
+ import numbers
+ import logging
+ from xml.dom.minidom import parseString
+@@ -96,7 +96,7 @@ def get_xml_type(val):
+ return 'null'
+ if isinstance(val, dict):
+ return 'dict'
+- if isinstance(val, collections.Iterable):
++ if isinstance(val, collections.abc.Iterable):
+ return 'list'
+ return type(val).__name__
+
+@@ -188,7 +188,7 @@ def convert(obj, ids, attr_type, item_func, cdata, parent='root'):
+ if isinstance(obj, dict):
+ return convert_dict(obj, ids, parent, attr_type, item_func, cdata)
+
+- if isinstance(obj, collections.Iterable):
++ if isinstance(obj, collections.abc.Iterable):
+ return convert_list(obj, ids, parent, attr_type, item_func, cdata)
+
+ raise TypeError('Unsupported data type: %s (%s)' % (obj, type(obj).__name__))
+@@ -232,7 +232,7 @@ def convert_dict(obj, ids, parent, attr_type, item_func, cdata):
+ )
+ )
+
+- elif isinstance(val, collections.Iterable):
++ elif isinstance(val, collections.abc.Iterable):
+ if attr_type:
+ attr['type'] = get_xml_type(val)
+ addline('<%s%s>%s</%s>' % (
+@@ -295,7 +295,7 @@ def convert_list(items, ids, parent, attr_type, item_func, cdata):
+ )
+ )
+
+- elif isinstance(item, collections.Iterable):
++ elif isinstance(item, collections.abc.Iterable):
+ if not attr_type:
+ addline('<%s %s>%s</%s>' % (
+ item_name, make_attrstring(attr),