summaryrefslogtreecommitdiff
path: root/dev-python/denonavr/denonavr-0.7.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/denonavr/denonavr-0.7.4.ebuild')
-rw-r--r--dev-python/denonavr/denonavr-0.7.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/denonavr/denonavr-0.7.4.ebuild b/dev-python/denonavr/denonavr-0.7.4.ebuild
new file mode 100644
index 000000000000..4a3aab119639
--- /dev/null
+++ b/dev-python/denonavr/denonavr-0.7.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Automation Library for Denon AVR receivers"
+HOMEPAGE="https://github.com/scarface-4711/denonavr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ py.test || die "tests failed with ${EPYTHON}"
+}