summaryrefslogtreecommitdiff
path: root/dev-python/defusedxml/defusedxml-0.7.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/defusedxml/defusedxml-0.7.1.ebuild')
-rw-r--r--dev-python/defusedxml/defusedxml-0.7.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/defusedxml/defusedxml-0.7.1.ebuild b/dev-python/defusedxml/defusedxml-0.7.1.ebuild
new file mode 100644
index 000000000000..3955f4c70145
--- /dev/null
+++ b/dev-python/defusedxml/defusedxml-0.7.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="XML bomb protection for Python stdlib modules, an xml serialiser"
+HOMEPAGE="https://pypi.org/project/defusedxml/"
+SRC_URI="
+ https://github.com/tiran/defusedxml/archive/v${PV/_/.}.tar.gz
+ -> ${P/_/.}.tar.gz"
+S=${WORKDIR}/${P/_/.}
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+distutils_enable_tests setup.py
+
+src_prepare() {
+ default
+
+ mv other examples || die
+}
+
+python_install_all() {
+ use examples && dodoc -r examples/
+ distutils-r1_python_install_all
+}