summaryrefslogtreecommitdiff
path: root/dev-python/defcon/defcon-0.9.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/defcon/defcon-0.9.0.ebuild')
-rw-r--r--dev-python/defcon/defcon-0.9.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/defcon/defcon-0.9.0.ebuild b/dev-python/defcon/defcon-0.9.0.ebuild
new file mode 100644
index 000000000000..7b058b3bee53
--- /dev/null
+++ b/dev-python/defcon/defcon-0.9.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A set of UFO based objects for use in font editing applications"
+HOMEPAGE="https://github.com/robotools/defcon"
+SRC_URI="https://github.com/robotools/defcon/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/fonttools-3.31.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/fs[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}