summaryrefslogtreecommitdiff
path: root/dev-python/debugpy
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/debugpy')
-rw-r--r--dev-python/debugpy/Manifest3
-rw-r--r--dev-python/debugpy/debugpy-1.4.1.ebuild39
-rw-r--r--dev-python/debugpy/metadata.xml15
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/debugpy/Manifest b/dev-python/debugpy/Manifest
new file mode 100644
index 000000000000..02447e94e7fb
--- /dev/null
+++ b/dev-python/debugpy/Manifest
@@ -0,0 +1,3 @@
+DIST debugpy-1.4.1.tar.gz 6687670 BLAKE2B c7761f354700d366d49365b0294ba1f07f357283c7527fc961c702bf99d808835741a899909e37092026c81ff19f6d96ef09c06512c8315ccad158b6e8e47697 SHA512 aef7779cb3a1af76b5cd3d6e8c7e0b78ffe08d1ebe25cf617ca3eb00966d5b3920358809c018f5f1f9eb56b913211134acfdba7d4c0d0174e4d6cfdae058d5f5
+EBUILD debugpy-1.4.1.ebuild 1052 BLAKE2B ad891f2789781b42198ec04e558aa8c05611ed9933430c84e7cb862f84d5803ac2a3e24173d566021b278f6d73d348601f3d0350187232d6d2a346b113208358 SHA512 aa6b5acdb4d2bbe5bbc7b90d78ce6f8aa824c9bc3eb548510f03d8682cf17869c71bcdcc003d02d2883646135846f45ee4630fcfe3ec2e1d1de0cd4318b98d92
+MISC metadata.xml 450 BLAKE2B 3f79fb2dc3ce19630fa2a268272de24b44618ffeb3ff71751976f83a76ddfa1a8f1266b09064228872ec1c26cb5124d520b835d93fc193c9138b12d54301cc22 SHA512 d41d73a2d79ea72997317b30526904e900becdddf0896e633bde612d0079e3e48d7449625f6117abfa2ec24a561bae1c1442b789935b42f6e3132fe21efc24f0
diff --git a/dev-python/debugpy/debugpy-1.4.1.ebuild b/dev-python/debugpy/debugpy-1.4.1.ebuild
new file mode 100644
index 000000000000..f49de56ebc48
--- /dev/null
+++ b/dev-python/debugpy/debugpy-1.4.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of the Debug Adapter Protocol for Python"
+HOMEPAGE="https://github.com/microsoft/debugpy/ https://pypi.org/project/debugpy/"
+SRC_URI="https://github.com/microsoft/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# There is not enough time in the universe for this test suite
+RESTRICT="test"
+
+# These files are included pre-built in the sources
+# TODO: Investigate what this is and if/how we can compile this properly
+QA_PREBUILT="
+ /usr/lib/python*/site-packages/${PN}/_vendored/pydevd/pydevd_attach_to_process/attach_linux_*.so
+"
+
+python_prepare_all() {
+ # Drop unnecessary and unrecognized option
+ # __main__.py: error: unrecognized arguments: -n8
+ # Do not timeout
+ sed -i \
+ -e 's/-n8//g' \
+ -e '/timeout/d' \
+ pytest.ini || die
+
+ distutils-r1_python_prepare_all
+}
+
+distutils_enable_tests pytest
diff --git a/dev-python/debugpy/metadata.xml b/dev-python/debugpy/metadata.xml
new file mode 100644
index 000000000000..a8dc72385883
--- /dev/null
+++ b/dev-python/debugpy/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">debugpy</remote-id>
+ <maintainer status="unknown">
+ <email>ptvshelp@microsoft.com</email>
+ <name>Microsoft Corporation</name>
+ </maintainer>
+ </upstream>
+</pkgmetadata>