summaryrefslogtreecommitdiff
path: root/dev-python/debugpy/debugpy-1.8.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/debugpy/debugpy-1.8.0.ebuild')
-rw-r--r--dev-python/debugpy/debugpy-1.8.0.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-python/debugpy/debugpy-1.8.0.ebuild b/dev-python/debugpy/debugpy-1.8.0.ebuild
index bf665f0da2e0..5324eccaca25 100644
--- a/dev-python/debugpy/debugpy-1.8.0.ebuild
+++ b/dev-python/debugpy/debugpy-1.8.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 multiprocessing
@@ -61,6 +61,15 @@ python_test() {
local EPYTEST_IGNORE=(
tests/tests/test_vendoring.py
)
+
+ case ${EPYTHON} in
+ python3.12)
+ EPYTEST_DESELECT+=(
+ tests/debugpy/test_flask.py
+ )
+ ;;
+ esac
+
epytest -p timeout -p xdist -n "$(makeopts_jobs)" --dist=worksteal \
-k "not attach_pid"
}