summaryrefslogtreecommitdiff
path: root/dev-python/dbutils/dbutils-3.0.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dbutils/dbutils-3.0.3.ebuild')
-rw-r--r--dev-python/dbutils/dbutils-3.0.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/dbutils/dbutils-3.0.3.ebuild b/dev-python/dbutils/dbutils-3.0.3.ebuild
new file mode 100644
index 000000000000..663d7ef65954
--- /dev/null
+++ b/dev-python/dbutils/dbutils-3.0.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=DBUtils
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Database connections for multi-threaded environments"
+HOMEPAGE="
+ https://webwareforpython.github.io/DBUtils/
+ https://github.com/WebwareForPython/DBUtils/
+ https://pypi.org/project/DBUtils/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ dodoc docs/*.rst
+ rm docs/*.rst || die
+ local HTML_DOCS=( docs/. )
+ distutils-r1_python_install_all
+}