summaryrefslogtreecommitdiff
path: root/dev-python/dbusmock/dbusmock-0.21.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dbusmock/dbusmock-0.21.0.ebuild')
-rw-r--r--dev-python/dbusmock/dbusmock-0.21.0.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-python/dbusmock/dbusmock-0.21.0.ebuild b/dev-python/dbusmock/dbusmock-0.21.0.ebuild
deleted file mode 100644
index 8ba3f1810b52..000000000000
--- a/dev-python/dbusmock/dbusmock-0.21.0.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-PYTHON_REQ_USE="xml(+)"
-
-inherit distutils-r1
-
-MY_PN="python-${PN}"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Easily create mock objects on D-Bus for software testing"
-HOMEPAGE="https://github.com/martinpitt/python-dbusmock"
-SRC_URI="https://github.com/martinpitt/${MY_PN}/releases/download/${PV}/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="LGPL-3+"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-
-RDEPEND="
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]"
-
-distutils_enable_tests unittest
-
-src_prepare() {
- # needed for unittest discovery
- > tests/__init__.py || die
-
- distutils-r1_src_prepare
-}