summaryrefslogtreecommitdiff
path: root/dev-python/dbusmock/dbusmock-0.20.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dbusmock/dbusmock-0.20.0.ebuild')
-rw-r--r--dev-python/dbusmock/dbusmock-0.20.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/dbusmock/dbusmock-0.20.0.ebuild b/dev-python/dbusmock/dbusmock-0.20.0.ebuild
new file mode 100644
index 000000000000..7a5a676663e2
--- /dev/null
+++ b/dev-python/dbusmock/dbusmock-0.20.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+MY_PN="python-${PN}"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Easily create mock objects on D-Bus for software testing"
+HOMEPAGE="https://github.com/martinpitt/python-dbusmock"
+SRC_URI="https://github.com/martinpitt/${MY_PN}/releases/download/${PV}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # broken by bluez5?
+ rm tests/test_bluez4.py || die
+ # needed for unittest discovery
+ > tests/__init__.py || die
+
+ distutils-r1_src_prepare
+}