summaryrefslogtreecommitdiff
path: root/dev-python/daemonize/daemonize-2.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/daemonize/daemonize-2.5.0.ebuild')
-rw-r--r--dev-python/daemonize/daemonize-2.5.0.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-python/daemonize/daemonize-2.5.0.ebuild b/dev-python/daemonize/daemonize-2.5.0.ebuild
index ace9fe951e98..c173bf76ab7d 100644
--- a/dev-python/daemonize/daemonize-2.5.0.ebuild
+++ b/dev-python/daemonize/daemonize-2.5.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -14,3 +14,7 @@ SRC_URI="https://github.com/thesharp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+
+python_test() {
+ "${EPYTHON}" tests/test.py -v || die "Tests failed with ${EPYTHON}"
+}