summaryrefslogtreecommitdiff
path: root/dev-python/cytoolz/cytoolz-0.10.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cytoolz/cytoolz-0.10.0.ebuild')
-rw-r--r--dev-python/cytoolz/cytoolz-0.10.0.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-python/cytoolz/cytoolz-0.10.0.ebuild b/dev-python/cytoolz/cytoolz-0.10.0.ebuild
deleted file mode 100644
index 3ef3b625078e..000000000000
--- a/dev-python/cytoolz/cytoolz-0.10.0.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Cython implementation of Toolz: High performance functional utilities"
-HOMEPAGE="https://pypi.org/project/cytoolz/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-# Informed by author the dep in toolz is not only required but the
-# tests are version sensitive.
-# https://github.com/pytoolz/cytoolz/issues/57
-RDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}]
- >=dev-python/toolz-0.8[${PYTHON_USEDEP}] )"
-
-python_test() {
- pushd "${BUILD_DIR}"/lib/ > /dev/null || die
- PYTHONPATH=.:${PN} nosetests --with-doctest ${PN} || die "tests failed under ${EPYTHON}"
- popd > /dev/null || die
-}