summaryrefslogtreecommitdiff
path: root/dev-python/cx_Freeze/cx_Freeze-6.5.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cx_Freeze/cx_Freeze-6.5.3.ebuild')
-rw-r--r--dev-python/cx_Freeze/cx_Freeze-6.5.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/cx_Freeze/cx_Freeze-6.5.3.ebuild b/dev-python/cx_Freeze/cx_Freeze-6.5.3.ebuild
new file mode 100644
index 000000000000..9599093bee6c
--- /dev/null
+++ b/dev-python/cx_Freeze/cx_Freeze-6.5.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python{3_7,3_8,3_9} )
+inherit distutils-r1
+
+DESCRIPTION="Create standalone executables from Python scripts"
+HOMEPAGE="https://cx-freeze.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PYTHON"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ # bug #491602
+ "${FILESDIR}/${PN}-6.5.3-buildsystem.patch"
+)
+
+# bug #765385
+RESTRICT="test"