summaryrefslogtreecommitdiff
path: root/dev-python/cryptography/cryptography-41.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cryptography/cryptography-41.0.1.ebuild')
-rw-r--r--dev-python/cryptography/cryptography-41.0.1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/cryptography/cryptography-41.0.1.ebuild b/dev-python/cryptography/cryptography-41.0.1.ebuild
index b302e47e0cfb..ab9db0bad0a0 100644
--- a/dev-python/cryptography/cryptography-41.0.1.ebuild
+++ b/dev-python/cryptography/cryptography-41.0.1.ebuild
@@ -65,7 +65,7 @@ CRATES="
windows_x86_64_msvc@0.42.2
"
-inherit cargo distutils-r1 multiprocessing pypi
+inherit cargo distutils-r1 flag-o-matic multiprocessing pypi
VEC_P=cryptography_vectors-$(ver_cut 1-3)
DESCRIPTION="Library providing cryptographic recipes and primitives"
@@ -136,6 +136,10 @@ src_prepare() {
fi
}
+python_configure_all() {
+ filter-lto # bug #903908
+}
+
python_test() {
local -x PYTHONPATH="${PYTHONPATH}:${WORKDIR}/cryptography_vectors-${PV}"
local EPYTEST_IGNORE=(