summaryrefslogtreecommitdiff
path: root/dev-python/crispy-bootstrap5/crispy-bootstrap5-0.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/crispy-bootstrap5/crispy-bootstrap5-0.7.ebuild')
-rw-r--r--dev-python/crispy-bootstrap5/crispy-bootstrap5-0.7.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/crispy-bootstrap5/crispy-bootstrap5-0.7.ebuild b/dev-python/crispy-bootstrap5/crispy-bootstrap5-0.7.ebuild
new file mode 100644
index 000000000000..334d9c3af66d
--- /dev/null
+++ b/dev-python/crispy-bootstrap5/crispy-bootstrap5-0.7.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="Bootstrap5 template pack for django-crispy-forms"
+HOMEPAGE="
+ https://pypi.org/project/crispy-bootstrap5/
+"
+SRC_URI="https://github.com/django-crispy-forms/${PN}/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/django-crispy-forms[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+PATCHES=( "${FILESDIR}"/${P}-test.patch )