summaryrefslogtreecommitdiff
path: root/dev-python/crc32c
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/crc32c')
-rw-r--r--dev-python/crc32c/Manifest4
-rw-r--r--dev-python/crc32c/crc32c-2.6.ebuild46
-rw-r--r--dev-python/crc32c/crc32c-2.7_p1.ebuild46
3 files changed, 0 insertions, 96 deletions
diff --git a/dev-python/crc32c/Manifest b/dev-python/crc32c/Manifest
index a51ad1fca9f3..1687b0a0cc0d 100644
--- a/dev-python/crc32c/Manifest
+++ b/dev-python/crc32c/Manifest
@@ -1,7 +1,3 @@
-DIST crc32c-2.6.tar.gz 42985 BLAKE2B 0193b26a56c6a2ec071231815cfcdf8ab3ce58de98e2948ab68c8ccd5779772923c8fd1464c70376ade8d4a6a38a575f8330791b7cda8de82d001a869b22e7e2 SHA512 7ca2614994b558c0f9b12fb743b0dadcfd6e6e3ab71c7550fd892324a91a90816b2dadf9c9946078e0ee2cd4abe14fdca385421bcd9468e41fd656a080b4d52e
DIST crc32c-2.7.1.tar.gz 45712 BLAKE2B 1aec82c981aaa4ff1e0858fb60df437c9c54cec5642cf5726c202ed1a682e9cf27ee2eeb6858ef3832fcbddbe9ffc244ce9bb1c8ffeeb4135a00858db3066d2a SHA512 2240339fa6b82ac16f5e4bf70d933a65dc2d32d4cbf62daaa1ba7d3dae0194de64a6e48c62a519dcdd261178b869abc0853634c45df14d23076f08dc2535225d
-DIST crc32c-2.7.post1.tar.gz 45229 BLAKE2B 37276efdeb3a3e23bd57795db775441b04d3a72db69dc3a5e9649404c5297ba2d3de39612f906e88f79d1fb39e83cd8a6b5d2d18dda23e6d5c1ccb4779edc557 SHA512 d529de2ec37c8fb4742db515d51d1dde4344617477d2a0c602baeb5f38446a7adda77fa63e3ff1a7e50a25dde147b86fd63a1d83f8f76bbbdf047280799cf360
-EBUILD crc32c-2.6.ebuild 1190 BLAKE2B e3bd619bf25c288df490d4c07f53e98a5a6fefe47c7c765558e9ac6f56eddd1f25054e8d41e7f5bf7b878b6c67f2421592f4b798351e86ee54baa93728397b39 SHA512 861a360abf34b9211588d379140ae8fd5259a106efd55f8a567d924e4d220a19ea16e4c019fe90e092afd10f3d0e9ff0ff082a8b1c18bab53eb6ac180ced8785
EBUILD crc32c-2.7.1.ebuild 1204 BLAKE2B 607a7a552790d55f3e57bc8c3af431828fce7eb5f0e0e436f54c29eeb65486526fdea18f5082b860e0ffb7655957e2a08e8540162f50922a94599863ea9f75de SHA512 22681b272e382e27893d1dc1a94ebf2a6901e1cf660b3282af998e485f20374aae9ef74e8f7bb5fac1b5fffe4fa73081b0a1cfffe94ef40545e8d35fea77a8c9
-EBUILD crc32c-2.7_p1.ebuild 1190 BLAKE2B e3bd619bf25c288df490d4c07f53e98a5a6fefe47c7c765558e9ac6f56eddd1f25054e8d41e7f5bf7b878b6c67f2421592f4b798351e86ee54baa93728397b39 SHA512 861a360abf34b9211588d379140ae8fd5259a106efd55f8a567d924e4d220a19ea16e4c019fe90e092afd10f3d0e9ff0ff082a8b1c18bab53eb6ac180ced8785
MISC metadata.xml 340 BLAKE2B 51d7b138caeb04c73b96d68973194bee9c7af76811fa6c886c5aa80415624d00adee76c4187f52bcc740a5f0fafbebd2b9207c5dac3ab191799598c2d5aa275d SHA512 b6c86d6aacc37c0c1fac0382407b9d8821a939e322281192254d95d1b066088268730f1ad7031b3ce9e9aa324db412a0a8ed060ab75d23155e2e682c6d80a93c
diff --git a/dev-python/crc32c/crc32c-2.6.ebuild b/dev-python/crc32c/crc32c-2.6.ebuild
deleted file mode 100644
index 73c73f15b871..000000000000
--- a/dev-python/crc32c/crc32c-2.6.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..13} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="CRC32c algorithm in hardware and software"
-HOMEPAGE="
- https://github.com/ICRAR/crc32c/
- https://pypi.org/project/crc32c/
-"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~sparc ~x86"
-# NB: these don't affect the build, they are only used for tests
-IUSE="cpu_flags_arm_crc32 cpu_flags_x86_sse4_2"
-
-distutils_enable_tests pytest
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x CRC32C_SW_MODE
-
- # force = run "software" code (i.e. unoptimized)
- # none = run "hardware" code (i.e. SSE4.2 / ARMv8 CRC32)
- for CRC32C_SW_MODE in none force; do
- if [[ ${CRC32C_SW_MODE} == none ]]; then
- if ! use cpu_flags_arm_crc32 && ! use cpu_flags_x86_sse4_2; then
- continue
- fi
-
- # the test suite just skips all tests, so double-check
- "${EPYTHON}" -c "import crc32c" ||
- die "Importing crc32c failed (accelerated code path broken?)"
- fi
-
- einfo "Testing with CRC32C_SW_MODE=${CRC32C_SW_MODE}"
- epytest
- done
-}
diff --git a/dev-python/crc32c/crc32c-2.7_p1.ebuild b/dev-python/crc32c/crc32c-2.7_p1.ebuild
deleted file mode 100644
index 73c73f15b871..000000000000
--- a/dev-python/crc32c/crc32c-2.7_p1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..13} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="CRC32c algorithm in hardware and software"
-HOMEPAGE="
- https://github.com/ICRAR/crc32c/
- https://pypi.org/project/crc32c/
-"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~sparc ~x86"
-# NB: these don't affect the build, they are only used for tests
-IUSE="cpu_flags_arm_crc32 cpu_flags_x86_sse4_2"
-
-distutils_enable_tests pytest
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x CRC32C_SW_MODE
-
- # force = run "software" code (i.e. unoptimized)
- # none = run "hardware" code (i.e. SSE4.2 / ARMv8 CRC32)
- for CRC32C_SW_MODE in none force; do
- if [[ ${CRC32C_SW_MODE} == none ]]; then
- if ! use cpu_flags_arm_crc32 && ! use cpu_flags_x86_sse4_2; then
- continue
- fi
-
- # the test suite just skips all tests, so double-check
- "${EPYTHON}" -c "import crc32c" ||
- die "Importing crc32c failed (accelerated code path broken?)"
- fi
-
- einfo "Testing with CRC32C_SW_MODE=${CRC32C_SW_MODE}"
- epytest
- done
-}