summaryrefslogtreecommitdiff
path: root/dev-python/coverage
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/coverage')
-rw-r--r--dev-python/coverage/Manifest4
-rw-r--r--dev-python/coverage/coverage-7.2.7.ebuild82
-rw-r--r--dev-python/coverage/coverage-7.3.0.ebuild82
3 files changed, 0 insertions, 168 deletions
diff --git a/dev-python/coverage/Manifest b/dev-python/coverage/Manifest
index cc9897e7d2b8..6178e2298b83 100644
--- a/dev-python/coverage/Manifest
+++ b/dev-python/coverage/Manifest
@@ -1,7 +1,3 @@
-DIST coverage-7.2.7.tar.gz 762575 BLAKE2B 20a800c3cd62095aacdfa4853613a3fd579abacd9051878ee2b308360db181ad45b68a0866236666826efc510d4a0328273d63c78c42fa4a7419ac98f85cf3f4 SHA512 01ed5ef8ddb600b8a7443200b568eb5d8aa7d652f408617f78a2e1251a5f091ee05188a7d383acd530f29b688b67a4bf2dc2e1241efffe8b9d0f70f44c646f33
-DIST coverage-7.3.0.tar.gz 763902 BLAKE2B dbd49200ef5ca167b9ae11b76bae1d8dd682289d14c657029227d0f2f1cc149ddde7c571add7165e10a150d2bd591d9bc988a7d306d01dd3eb34e8a5098d66cd SHA512 3b394c3c96ca8484641585ce26c27100153892a77369e14e3596fe604a98ac0f9b33189d679fffd9fa80a41ac4bfa6a64dfe97e586833b39707ecc7f5aa43c35
DIST coverage-7.3.1.tar.gz 764806 BLAKE2B 7399c7df63d0a546e20797c52780376bb8f65578753ffae3bb15901bd4fb7b4c0d8360b2dbc445e038d226af9ddf0b39c38c16fa70d9690b62477e5e75dfb51d SHA512 deeeab41ca53cdda83fe233f63bcf14909b96dfa0710d882dcaa9f81f4884ef7b39aaf177f832ce0f66f1fb88ad4b97d37ef2adfa2540d551352ed48af1926b2
-EBUILD coverage-7.2.7.ebuild 2026 BLAKE2B 141b94150df42785484b49d7b101c4cdb88154af6eb77dcf7a1dd0614ac61a9dab2c37fcd1bd729308264b9cb16e3e0824f3175de86cb4fe4d52672dec0a4696 SHA512 712062ea525454a6787d5388ace87466146ddcd39a48b639a0b194793b801f80fc39d09214c4a89dabfa86dd3b6423ba9f603bec2948597b8be34f3f0ada4424
-EBUILD coverage-7.3.0.ebuild 2034 BLAKE2B 5e4cf3e6145634a04ecc6c9dfb322afb01ba75d3eb89decad37ccf056326394252a3579921056bdf8e42f112a4c04ca8f8bf983f049ccef6c76d89b3ef9c3851 SHA512 42fcc4abb0253d296586eb96848d56ce5b9c25548f837e68eb1e0162ad7e843730d7bb6d93d86316620e1741ceddd2034a354e5e44286e90f1e1018700d9730a
EBUILD coverage-7.3.1.ebuild 2026 BLAKE2B 886fdfdcc5139439f217ff82edf89f77cd9899b208350ac6373b33f88d2cb46db6c7eb4a295f42dd096f9bcd74345adf9e8433b17608358e034672a19c41c71c SHA512 8b5f83577f9a9b6a49048ef7240abcdb4acc77d70a538cb7e5c16e98d408247e5ec70730c3dc197cd480e10e83d6dfb56d52fc648aeffcf4aee48b4d9957f091
MISC metadata.xml 771 BLAKE2B 38e9680d0851f70050aad987714a9dd2f95178b0bc3d794dc08726c0618d1ea98be32a413ac397f4b222e8a5d8fdc747b7f1677bcfe842bac4080537e85a03a9 SHA512 8c44c40348fe5d416d8b4016fe22cc9ae0b94fbaf181deb79aa737f87271992521b710c1208d0eeb7ef92d96fc8a7daac1ec6feb1ae081a80f13327b5b094064
diff --git a/dev-python/coverage/coverage-7.2.7.ebuild b/dev-python/coverage/coverage-7.2.7.ebuild
deleted file mode 100644
index 84538807bdf2..000000000000
--- a/dev-python/coverage/coverage-7.2.7.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-PYTHON_REQ_USE="threads(+),sqlite(+)"
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Code coverage measurement for Python"
-HOMEPAGE="
- https://coverage.readthedocs.io/en/latest/
- https://github.com/nedbat/coveragepy/
- https://pypi.org/project/coverage/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-RDEPEND="
- $(python_gen_cond_dep '
- dev-python/tomli[${PYTHON_USEDEP}]
- ' 3.{8..10})
-"
-BDEPEND="
- test? (
- dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- >=dev-python/unittest-mixins-1.4[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -i -e '/addopts/s:-q -n auto::' pyproject.toml || die
- distutils-r1_src_prepare
-}
-
-test_tracer() {
- local -x COVERAGE_TEST_TRACER=${1}
- einfo " Testing with the ${COVERAGE_TEST_TRACER} tracer ..."
- epytest tests
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # TODO: fails because of additional "Terminated" print on SIGTERM
- tests/test_concurrency.py::SigtermTest::test_sigterm_threading_saves_data
- )
- local EPYTEST_IGNORE=(
- # pip these days insists on fetching build deps from Internet
- tests/test_venv.py
- )
-
- "${EPYTHON}" igor.py zip_mods || die
-
- local -x COVERAGE_TESTING=True
- # TODO: figure out why they can't be imported inside test env
- local -x COVERAGE_NO_CONTRACTS=1
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=_hypothesis_pytestplugin,flaky.flaky_pytest_plugin,xdist.plugin
-
- local prev_opt=$(shopt -p nullglob)
- shopt -s nullglob
- local c_ext=( "${BUILD_DIR}/install$(python_get_sitedir)"/coverage/*.so )
- ${prev_opt}
-
- if [[ -n ${c_ext} ]]; then
- cp "${c_ext}" \
- coverage/ || die
- test_tracer c
- rm coverage/*.so || die
- else
- test_tracer py
- fi
-}
diff --git a/dev-python/coverage/coverage-7.3.0.ebuild b/dev-python/coverage/coverage-7.3.0.ebuild
deleted file mode 100644
index 1f84c952787b..000000000000
--- a/dev-python/coverage/coverage-7.3.0.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-PYTHON_REQ_USE="threads(+),sqlite(+)"
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Code coverage measurement for Python"
-HOMEPAGE="
- https://coverage.readthedocs.io/en/latest/
- https://github.com/nedbat/coveragepy/
- https://pypi.org/project/coverage/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
-
-RDEPEND="
- $(python_gen_cond_dep '
- dev-python/tomli[${PYTHON_USEDEP}]
- ' 3.{9..10})
-"
-BDEPEND="
- test? (
- dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- >=dev-python/unittest-mixins-1.4[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -i -e '/addopts/s:-q -n auto::' pyproject.toml || die
- distutils-r1_src_prepare
-}
-
-test_tracer() {
- local -x COVERAGE_TEST_TRACER=${1}
- einfo " Testing with the ${COVERAGE_TEST_TRACER} tracer ..."
- epytest tests
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # TODO: fails because of additional "Terminated" print on SIGTERM
- tests/test_concurrency.py::SigtermTest::test_sigterm_threading_saves_data
- )
- local EPYTEST_IGNORE=(
- # pip these days insists on fetching build deps from Internet
- tests/test_venv.py
- )
-
- "${EPYTHON}" igor.py zip_mods || die
-
- local -x COVERAGE_TESTING=True
- # TODO: figure out why they can't be imported inside test env
- local -x COVERAGE_NO_CONTRACTS=1
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=_hypothesis_pytestplugin,flaky.flaky_pytest_plugin,xdist.plugin
-
- local prev_opt=$(shopt -p nullglob)
- shopt -s nullglob
- local c_ext=( "${BUILD_DIR}/install$(python_get_sitedir)"/coverage/*.so )
- ${prev_opt}
-
- if [[ -n ${c_ext} ]]; then
- cp "${c_ext}" \
- coverage/ || die
- test_tracer c
- rm coverage/*.so || die
- else
- test_tracer py
- fi
-}