summaryrefslogtreecommitdiff
path: root/dev-python/coverage/coverage-4.5.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/coverage/coverage-4.5.4.ebuild')
-rw-r--r--dev-python/coverage/coverage-4.5.4.ebuild28
1 files changed, 0 insertions, 28 deletions
diff --git a/dev-python/coverage/coverage-4.5.4.ebuild b/dev-python/coverage/coverage-4.5.4.ebuild
deleted file mode 100644
index 53d540410141..000000000000
--- a/dev-python/coverage/coverage-4.5.4.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Code coverage measurement for Python"
-HOMEPAGE="https://coverage.readthedocs.io/en/latest/ https://pypi.org/project/coverage/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~ia64 ~mips ppc ppc64 ~s390 sparc x86"
-RESTRICT="test"
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_compile() {
- if [[ ${EPYTHON} == python2.7 ]]; then
- local CFLAGS="${CFLAGS} -fno-strict-aliasing"
- export CFLAGS
- fi
-
- distutils-r1_python_compile
-}