summaryrefslogtreecommitdiff
path: root/dev-python/contourpy
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/contourpy')
-rw-r--r--dev-python/contourpy/Manifest2
-rw-r--r--dev-python/contourpy/contourpy-1.2.1.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/contourpy/Manifest b/dev-python/contourpy/Manifest
index 4d005ef722d9..cf87e99c1870 100644
--- a/dev-python/contourpy/Manifest
+++ b/dev-python/contourpy/Manifest
@@ -1,4 +1,6 @@
AUX contourpy-1.2.0-unicore.patch 3169 BLAKE2B 436bd8b179be7bb695694de4254be53fc0915a1ce362966ec6c9c718da735155ac045ba8fd5c34b696b3700aa9e7646fa8ac65466172e8a466629151cbf06a27 SHA512 cbfc980b3bc300a36e4c11e7b59b06ec85a36930ae8a95e7f05e69747da4ee0425a5b684c1e22e0e40c534ff1e2dedee1f99d8e60af2e8d71a1daa68115132c2
DIST contourpy-1.2.0.gh.tar.gz 13440145 BLAKE2B c8082f69c3c8ad2b9a2d7a8e68941f1b741b0527161df371b501a32b8f0572a012aa2184b9f3ea943f45143f218f910180e31371683826d2b9b9431537c72cbd SHA512 91084ca659f796fb49f34840fb08a1a8f2a78ce8264668f5729550b1c46f316933c1d76ed87797bf58a059f0cf63e6efc58c92e44c57787fc8ad1ca16a21aa6e
+DIST contourpy-1.2.1.gh.tar.gz 13440991 BLAKE2B 2e792ca990244f7890462b84a2f23e4fbc31fd8ce0a18bc8724767dfa4b5fc0a4271dc6989531423db58d567706a28ce95e680372dbf64bae93a09914353f3ac SHA512 2bb2ac7436cbee1ebc69e6edaf3166e294de32711cec506ce9a3132f1cf20ff8de70af27b432b81abb582c9fe30239f8724f68936908bdbf6348eb249eaae4d5
EBUILD contourpy-1.2.0.ebuild 1187 BLAKE2B e613e2b73ef5e75469120325fff1a129416172d0744f1018fb161d95b3d96e2244f5a349c9769368d91b50b385c6356674a544a3016d9e2571cb57ec196afb31 SHA512 2d278ba176faf8c58cf8359449724e1e11509cd2431b01fee2b326cac723099933f99eb0035e266d2b5a5fc2227dde1d888ef86c8a3e327beff153939b9fb9d7
+EBUILD contourpy-1.2.1.ebuild 1100 BLAKE2B bb0f1e382a6869c5758aa0ca4fe5f30be9f9f0f47d452c647dc7dd9d9fd43bf3ef86e0fe1cbf7d49e745c7763733a225f96794121aaeef34dd2d3b37bb326407 SHA512 775607bf91445ef40782646d3d4279a3d4c1ac78684f76bcf39ef7aa00452c353b3982308157398e9ce21475561aff1fae9dd71756e2c1c06ca3c85b2c795d5e
MISC metadata.xml 372 BLAKE2B de3d6cc9d8727bf43be63fdbb8aa2ad375667d189019e189be262e39d028acab98a21e200798c2d5c5c72521aa7d38202e3e235dd44de9b43a7dc9e045d50c47 SHA512 e692f94d805d7f56fc895a4c76dfbacf2f068d687b9191482b946445baa3bd0a685eda7a1b0aec2aaf9a02e6f23d87f0bf22d90f42e3c21d930724c635ff859a
diff --git a/dev-python/contourpy/contourpy-1.2.1.ebuild b/dev-python/contourpy/contourpy-1.2.1.ebuild
new file mode 100644
index 000000000000..ad2ce4bb078e
--- /dev/null
+++ b/dev-python/contourpy/contourpy-1.2.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=meson-python
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for calculating contours in 2D quadrilateral grids"
+HOMEPAGE="
+ https://pypi.org/project/contourpy/
+ https://github.com/contourpy/contourpy/
+"
+SRC_URI="
+ https://github.com/contourpy/contourpy/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/numpy-1.20[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pybind11-2.12.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/wurlitzer[${PYTHON_USEDEP}]
+ )
+"
+
+DISTUTILS_ARGS=(
+ -Dwerror=false
+)
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # linters
+ tests/test_codebase.py
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}