summaryrefslogtreecommitdiff
path: root/dev-python/contourpy/contourpy-1.0.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/contourpy/contourpy-1.0.7.ebuild')
-rw-r--r--dev-python/contourpy/contourpy-1.0.7.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/contourpy/contourpy-1.0.7.ebuild b/dev-python/contourpy/contourpy-1.0.7.ebuild
deleted file mode 100644
index 1f9ceba771e4..000000000000
--- a/dev-python/contourpy/contourpy-1.0.7.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library for calculating contours in 2D quadrilateral grids"
-HOMEPAGE="
- https://pypi.org/project/contourpy/
- https://github.com/contourpy/contourpy/
-"
-SRC_URI="
- https://github.com/contourpy/contourpy/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/numpy-1.16[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/pybind11-2.6[${PYTHON_USEDEP}]
- test? (
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_IGNORE=(
- # linters
- tests/test_codebase.py
- )
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- # threaded algorithms are known to be broken
- # https://github.com/contourpy/contourpy/issues/163
- epytest -k "not threaded and not threads"
-}