summaryrefslogtreecommitdiff
path: root/dev-python/construct
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/construct')
-rw-r--r--dev-python/construct/Manifest5
-rw-r--r--dev-python/construct/construct-2.8.17.ebuild27
-rw-r--r--dev-python/construct/construct-2.8.21.ebuild27
-rw-r--r--dev-python/construct/metadata.xml16
4 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/construct/Manifest b/dev-python/construct/Manifest
new file mode 100644
index 000000000000..c2f613507d1d
--- /dev/null
+++ b/dev-python/construct/Manifest
@@ -0,0 +1,5 @@
+DIST construct-2.8.17.tar.gz 705812 BLAKE2B 3178f7f59fb893bc521c88b7ba51d6bd83cca37c1a243e602dcc2ac41a2cb7335e2cf69e7dff3b130e974ff9dbd01a12004423c3a88fc8e88c784c665437e901 SHA512 5bca40d7f33f336ab2a66546027c8bf24bf1b0125bcf425063b3bab14b1e3a96577d602db1eb73cb0ee99f90d92af6e24fcbd228912c0a70de6b2bd7d33e75be
+DIST construct-2.8.21.tar.gz 706022 BLAKE2B a7fb81185b380b444bede5dffce11158d93f0076cc3fbd836cdef3cf8425e2bcce0cf7b8e2d2654effc8beac3d3d0f722dd2786103f9b85f05b98216fc7684cb SHA512 f8e2c8d0f437cce760b1439fc68e2b10dccf852e1bf3c42e0569a3e32fe218d2a4d4cc662229455a910fa8a7cf0fc0500cb0d38ad0485f1b9fd954334f343562
+EBUILD construct-2.8.17.ebuild 705 BLAKE2B a5408e8503f1dc3f385df1d33e4820da5124a25f38c0b52bee2691ddcd01f3b803babbe56896dd462aba09ef6bc35498e6d74b46bad0c22e9fc4493f1c4c6910 SHA512 00232ecc1cfeec4a51eeada13981f64591e32b690bc1bed9b517daca593f756e7f363a6e0cf1a00135275d4ccc1e54e447c16e6a55d623b1218da0ae8cbda713
+EBUILD construct-2.8.21.ebuild 709 BLAKE2B 65b39cdf67fa290213e03307e2e8f62d3e58bf6436b26b0bb5cdebff8709f7e7d9085198e5eb5468fafb12725088ae4ed087e85fb863cd66a05a9bcfbac228e0 SHA512 67f328f601d00917057d0c6e6b47ff41899f51e139bdbd0d26a918f053ee94592f8eba1e639eca19b91840782e53ec386757a920e370c00449daa3920093d367
+MISC metadata.xml 491 BLAKE2B bf8f7729988a0a4c39c9f8081a4b05560d1596a69c8670e378ea1f1f81b8dd5a2c366e8211c36e07f809378c6ae769b01181a4ceaf3f82ec8eb2b1879d874a87 SHA512 a8a85937bda8fb36a51bd6e0c0bcb1ce721073ee07a8e198c88b64ee484e8fd1c813e937443885e5ea2e532cda3971e8eb59385797a7a8f44ec9524a57acbbf9
diff --git a/dev-python/construct/construct-2.8.17.ebuild b/dev-python/construct/construct-2.8.17.ebuild
new file mode 100644
index 000000000000..4235c921ade4
--- /dev/null
+++ b/dev-python/construct/construct-2.8.17.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A powerful declarative parser for binary data"
+HOMEPAGE="http://construct.readthedocs.io/ https://pypi.org/project/construct/"
+SRC_URI="https://github.com/construct/construct/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/tox[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -vv || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/construct/construct-2.8.21.ebuild b/dev-python/construct/construct-2.8.21.ebuild
new file mode 100644
index 000000000000..be8e7c29cc9d
--- /dev/null
+++ b/dev-python/construct/construct-2.8.21.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A powerful declarative parser for binary data"
+HOMEPAGE="http://construct.readthedocs.io/ https://pypi.org/project/construct/"
+SRC_URI="https://github.com/construct/construct/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/tox[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -vv || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/construct/metadata.xml b/dev-python/construct/metadata.xml
new file mode 100644
index 000000000000..d884045ff57e
--- /dev/null
+++ b/dev-python/construct/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>azamat.hackimov@gmail.com</email>
+ <name>Azamat H. Hackimov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">construct/construct</remote-id>
+ <remote-id type="pypi">construct</remote-id>
+ </upstream>
+</pkgmetadata>