summaryrefslogtreecommitdiff
path: root/dev-python/constantly/constantly-15.1.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/constantly/constantly-15.1.0-r1.ebuild')
-rw-r--r--dev-python/constantly/constantly-15.1.0-r1.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/dev-python/constantly/constantly-15.1.0-r1.ebuild b/dev-python/constantly/constantly-15.1.0-r1.ebuild
index e3b36e5d7bb5..fca5a2c60885 100644
--- a/dev-python/constantly/constantly-15.1.0-r1.ebuild
+++ b/dev-python/constantly/constantly-15.1.0-r1.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
inherit distutils-r1
@@ -17,9 +18,7 @@ IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND=""
-DEPEND="
- ${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
+DEPEND="${RDEPEND}
test? ( dev-python/twisted[${PYTHON_USEDEP}] )
"