summaryrefslogtreecommitdiff
path: root/dev-python/commentjson
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/commentjson')
-rw-r--r--dev-python/commentjson/Manifest3
-rw-r--r--dev-python/commentjson/commentjson-0.9.0-r2.ebuild12
-rw-r--r--dev-python/commentjson/files/commentjson-0.9.0-py312.patch24
3 files changed, 35 insertions, 4 deletions
diff --git a/dev-python/commentjson/Manifest b/dev-python/commentjson/Manifest
index b93286752647..9bbc4008a6df 100644
--- a/dev-python/commentjson/Manifest
+++ b/dev-python/commentjson/Manifest
@@ -1,3 +1,4 @@
+AUX commentjson-0.9.0-py312.patch 996 BLAKE2B e13cd38728e7207f7f88897dc5a27d238acd8246df174892cfbbad14e2e3e14abbaf04fbe68d5c5abf8dc0a64824e364f9435055ccddfcc4427936ba83e401f6 SHA512 ff442f4bf916703a4231607d8b79f16d71e8b03665deb9431f438edce12075eb1cc784413bdfd23e580e149c8f150cbe8ea137b3b1e6d046d83204e29264c470
DIST commentjson-0.9.0.gh.tar.gz 15297 BLAKE2B a857b0fa5551079d3d37bff94fb51a903e998c4fb84e0f62a5de28d6eafe0cb8a38b3215515e72c56de0cddb661f109921c801d15b9ba93771290135adaaa5b1 SHA512 cd3d28adecbc445ed3faed7847c65a23829f408cf8aa3fa85544a0f0cf9fa5544b8aff560725cf51921f249123daf9ce9953069e99ca64a312bb4bff652512fe
-EBUILD commentjson-0.9.0-r2.ebuild 834 BLAKE2B f53c8b6cc79ed27efb013dd22075e5b1ca84c518bb25165bc70048c660dcbe967d5aedc80b517830fc3bdd255cf6d9922e85d4c3d790754b17f26e994cbb6ec6 SHA512 9d7724a6bec25ffb64593d15fba5dd78fb42e4323b019f402d7af9075d04b9c48ec930addf31c8aa088cf2b293e4fad97933ade6b0d89c2ed847d9d31907a2bb
+EBUILD commentjson-0.9.0-r2.ebuild 939 BLAKE2B 01c47fb67bbb69ffb893cf12ecf9f9b76fa8f7a71c8dad11a069fb5000ea883a345c17f912da9b1cbc7eb355a59c425c5ad35ddd0fc6fba7b7d090cb3fb897c5 SHA512 67d260dadc9a64cb3cc36e2043b343dd2b238922ba6abaeef39c8d872f6c0fa8ede11e96a3ec47986b7150b4f6ce2747ba0d99833a239800ddb6c650f94a5bf7
MISC metadata.xml 375 BLAKE2B 7391dadca9ed1ad8c62515f56347a04fe099c5020b2cfb5d6037e1057199f20a9a512c90800f81186bced7a8ff3f192b36e8c83d7d5ca2b961ea5f5a0e799e80 SHA512 005e5180f3f69d3c162b5ed113840494e0afbc9c09b5c4f02bad97ed7bf5a77e4b7806462f9c7aa3ca72d5d963e5d4b85a591e6e557742685c5738d66214915e
diff --git a/dev-python/commentjson/commentjson-0.9.0-r2.ebuild b/dev-python/commentjson/commentjson-0.9.0-r2.ebuild
index 6ebede96a2b3..66ef695160cc 100644
--- a/dev-python/commentjson/commentjson-0.9.0-r2.ebuild
+++ b/dev-python/commentjson/commentjson-0.9.0-r2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 2021-2023 Gentoo Authors
+# Copyright 2021-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
inherit distutils-r1
@@ -34,7 +34,13 @@ BDEPEND="
distutils_enable_tests unittest
src_prepare() {
+ local PATCHES=(
+ # https://github.com/vaidik/commentjson/pull/54
+ "${FILESDIR}/${P}-py312.patch"
+ )
+
+ distutils-r1_src_prepare
+
# remove lark-parser dependency to allow painless upgrade to lark
sed -e '/lark-parser/d' -i setup.py || die
- distutils-r1_src_prepare
}
diff --git a/dev-python/commentjson/files/commentjson-0.9.0-py312.patch b/dev-python/commentjson/files/commentjson-0.9.0-py312.patch
new file mode 100644
index 000000000000..dbdcfe488f83
--- /dev/null
+++ b/dev-python/commentjson/files/commentjson-0.9.0-py312.patch
@@ -0,0 +1,24 @@
+From 04ad293f800039c0221ff010236e589a4ba7079d Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sun, 23 Jun 2024 14:54:42 +0200
+Subject: [PATCH] Update test skips for Python 3.12+
+
+Python 3.12 moves testing for `Infinity` and other constants
+into `test_json/test_decode.py::test_parse_constant`.
+---
+ commentjson/tests/test_json/test_decode.py | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/commentjson/tests/test_json/test_decode.py b/commentjson/tests/test_json/test_decode.py
+index 6971c44..8f5e904 100644
+--- a/commentjson/tests/test_json/test_decode.py
++++ b/commentjson/tests/test_json/test_decode.py
+@@ -69,3 +69,8 @@ def test_string_with_utf8_bom(self):
+ 'test case is not supported by commentjson.'))
+ def test_negative_index(self):
+ pass
++
++ @unittest.skipIf(version >= (3, 12),
++ 'Infinity as a value is not supported yet')
++ def test_parse_constant(self):
++ pass