summaryrefslogtreecommitdiff
path: root/dev-python/comm
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/comm')
-rw-r--r--dev-python/comm/Manifest2
-rw-r--r--dev-python/comm/comm-0.2.0.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/comm/Manifest b/dev-python/comm/Manifest
index 0f9791ccd3ad..443b1ce15af1 100644
--- a/dev-python/comm/Manifest
+++ b/dev-python/comm/Manifest
@@ -1,3 +1,5 @@
DIST comm-0.1.4.gh.tar.gz 7504 BLAKE2B e020809077f5366737453fc8e56dc5b7751effc99f4766fddf1eecfa9a560aad7f17b56987ba072c5412a77761b3b978cfab34cbf62bd29e58160075e20d203d SHA512 5a3993b17d249a8c1be20ed8647ac0621517d500b4b933c78c05386d23d6d660175679a779a3a20818703f5c962c9a351916715a4f244b989ff2f6568382146a
+DIST comm-0.2.0.gh.tar.gz 8936 BLAKE2B 0ca702f3e4aa2a06f827a4896a3497cd98d1e4bafbf9d92942d8d9c6ee8f81b1300a3f2ae72ba32833574444e4d2a4a1fc20be70638333edcbdc2854ee612708 SHA512 6336d9ff2fcf9016d3616ec5c7f6715e8abffc878a0f5b8dabcd06cd17f851cf562e918bd43b55e435adf6da1e635e7152c3b525a5d718b04e7f98b3c8096505
EBUILD comm-0.1.4.ebuild 707 BLAKE2B 6e2e0ee8956153b7e1852607f1df4eab0f9f73712002c81f5a9bbc81dac63c991b3c8c560a85b27f0184fe32d826c33ab5a7eb886242f501be628fea20eb0d9b SHA512 08d4d6b7c697a664eefa1b92508f12f1cb7736961ec027a1c881f42322d595652632a06d711dba2dfadf06e67a611f5318469d1208b6c1bc2c238bd193013b09
+EBUILD comm-0.2.0.ebuild 715 BLAKE2B 18b69279faabbe793623c6d88582e63e14ad99becd6cfc31f8d7aafa779dc1b00c5df9a1ded6f6c6793dbc564d4707e6c1c076421dfae47c164ceb84b47937e5 SHA512 cac272c2bac51815f32974140da72e8e42cf74363700c8ae83e3c0dd455be2216f3213d3a9953ea5193a1560d9823b71a6ebafe85b4fc7c4851b0a02ef7a2d01
MISC metadata.xml 384 BLAKE2B c122aaf6c2b9e6776b19efa2549030f0267c1d553f92862c5ecf21926f30a9c3cd7564434a573cca6fdbb85485eb49213b4d95100e8de2a29ced9c9c1fa81153 SHA512 b06853ad3cb1775ad70e44c48bca74bcf85c11715291974e7e3ee496344256fc57b91920812f19809e7cf14f6a7f7938531934d6a12740baec0dd984d5d48632
diff --git a/dev-python/comm/comm-0.2.0.ebuild b/dev-python/comm/comm-0.2.0.ebuild
new file mode 100644
index 000000000000..c656e0b0741c
--- /dev/null
+++ b/dev-python/comm/comm-0.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter Python Comm implementation, for usage in ipykernel, xeus-python"
+HOMEPAGE="
+ https://github.com/ipython/comm/
+ https://pypi.org/project/comm/
+"
+# no tests in sdist, as of 0.1.3
+SRC_URI="
+ https://github.com/ipython/comm/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/traitlets-4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest