summaryrefslogtreecommitdiff
path: root/dev-python/coloredlogs/coloredlogs-10.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/coloredlogs/coloredlogs-10.0.ebuild')
-rw-r--r--dev-python/coloredlogs/coloredlogs-10.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/coloredlogs/coloredlogs-10.0.ebuild b/dev-python/coloredlogs/coloredlogs-10.0.ebuild
new file mode 100644
index 000000000000..6c4a97d80c70
--- /dev/null
+++ b/dev-python/coloredlogs/coloredlogs-10.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Colored stream handler for the logging module"
+HOMEPAGE="
+ https://pypi.org/project/coloredlogs/
+ https://github.com/xolox/python-coloredlogs
+ https://coloredlogs.readthedocs.io/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-python/humanfriendly[${PYTHON_USEDEP}]"
+
+DEPEND="test? (
+ dev-python/capturer[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/verboselogs[${PYTHON_USEDEP}] )"
+
+PATCHES="${FILESDIR}/${P}-skip-sandbox-violation-tests.patch"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_test() {
+ pytest -vv ${PN}/tests.py || die "Tests fail with ${EPYTHON}"
+}