summaryrefslogtreecommitdiff
path: root/dev-python/cmd2
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cmd2')
-rw-r--r--dev-python/cmd2/Manifest2
-rw-r--r--dev-python/cmd2/cmd2-2.5.9.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/cmd2/Manifest b/dev-python/cmd2/Manifest
index 725d081443a3..36cd3620b147 100644
--- a/dev-python/cmd2/Manifest
+++ b/dev-python/cmd2/Manifest
@@ -1,3 +1,5 @@
DIST cmd2-2.5.8.tar.gz 592395 BLAKE2B 52ea8ffd83dc8fdc904bba8b0bc72960d3782d0bf43a7dcb99b00d68f5bc4fcb5d17ddbe44655cb812bceed861a0dfd8d8753d818233dd9b1ad0e4461ce29eff SHA512 ce19006dff46279f14ac7d23ab4177b7926b061565ceff054291a508773ed0c037bdd20ffc72ecc99d44bcbc3751a486a14dd9d1d43c2e61a7ebd45cf967f06c
+DIST cmd2-2.5.9.tar.gz 883164 BLAKE2B 386c713e5bede98516842965c42f16abf97daaea1b52d8e2beaae04d32bcdfc419d00d5c48bff95dfc703be6dc073327da6dd8aeac947451218ac1f6e06d7632 SHA512 09d742728a964cbc6d01668b554c71535025834f46b1bae36cded63fc07234d0b53c5adae712437826f3df863b80734d7a78b6c36389bffab93201871be9eca1
EBUILD cmd2-2.5.8.ebuild 1327 BLAKE2B 078b7655fd5eb68b125fda7ff42a366a869d30bc1e64f7770f53ed9f0940814defdbebbf2ae1497315e4f2dae8bfad2ad433334c897b5d533da2fdf9e5744c87 SHA512 7e242331ac54c9253c988d6dc1bfe1a5d1d5ecb0e3894713d4e96596a66f7fc2aa792ccbdca961be0b969275c51769494cf03e6e477981f5f13192a03de553c3
+EBUILD cmd2-2.5.9.ebuild 1427 BLAKE2B 70db989779da6578537091143cba50703ce44356d94f09eae9a5e5f70a7084b09ebb62d37733d898823ef1b933d8b09be4747be37ba6ef63b8526756d1222cc3 SHA512 72ed159aa92e85c7f62fcd58910a9045fa3044a58f8ac10d40024abe9d8a4f623b83ce0fb83fb16ed63a7e311281c9745765dc598faaca8d55e7ae23eb4fd6da
MISC metadata.xml 522 BLAKE2B 39d319b6a64a7b54568a3fbd3d7db9adf7719b690a8f086018ce41f0595db157b1f7825ce28afb4fb0d748ca0d6dc21d79e480361b69b4bf29c0efc2d2540bba SHA512 57315c23dd64534085502e59f0b8ca01ef8088d5a2b16ed807631a1f36a523768960754b00619e802333552c405e2984e314d91003f7a624da6f1eb8e8e4b98a
diff --git a/dev-python/cmd2/cmd2-2.5.9.ebuild b/dev-python/cmd2/cmd2-2.5.9.ebuild
new file mode 100644
index 000000000000..a4d7d976d043
--- /dev/null
+++ b/dev-python/cmd2/cmd2-2.5.9.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 virtualx pypi
+
+DESCRIPTION="Extra features for standard library's cmd module"
+HOMEPAGE="
+ https://github.com/python-cmd2/cmd2/
+ https://pypi.org/project/cmd2/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/pyperclip-1.8[${PYTHON_USEDEP}]
+ >=dev-python/wcwidth-0.2.10[${PYTHON_USEDEP}]
+"
+# pyperclip uses clipboard backends in the following preference order:
+# pygtk, xclip, xsel, klipper, qtpy, pyqt5, pyqt4.
+# klipper is known to be broken in Xvfb, and therefore causes test
+# failures. to avoid them, we must ensure that one of the backends
+# preferred to it is available (i.e. xclip or xsel).
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ || (
+ x11-misc/xclip
+ x11-misc/xsel
+ )
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ # tests rely on very specific text wrapping...
+ local -x COLUMNS=80
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # TODO: tests_isolated?
+ epytest -o addopts= -p pytest_mock -p rerunfailures --reruns=5 tests || die
+}