summaryrefslogtreecommitdiff
path: root/dev-python/cmd2/cmd2-0.7.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cmd2/cmd2-0.7.5.ebuild')
-rw-r--r--dev-python/cmd2/cmd2-0.7.5.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/cmd2/cmd2-0.7.5.ebuild b/dev-python/cmd2/cmd2-0.7.5.ebuild
deleted file mode 100644
index ce1260582f8b..000000000000
--- a/dev-python/cmd2/cmd2-0.7.5.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Extra features for standard library's cmd module"
-HOMEPAGE="https://github.com/python-cmd2/cmd2"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-# restrict tests because pyperclip is fairly unstable...
-RESTRICT="test"
-
-RDEPEND="
- >=dev-python/pyparsing-2.0.1[${PYTHON_USEDEP}]
- dev-python/pyperclip[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-python_test() {
- py.test -vv || die
- ${EPYTHON} example/example.py --test example/exampleSession.txt || die
-}