summaryrefslogtreecommitdiff
path: root/dev-python/cmd2
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cmd2')
-rw-r--r--dev-python/cmd2/Manifest2
-rw-r--r--dev-python/cmd2/cmd2-2.5.8.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/cmd2/Manifest b/dev-python/cmd2/Manifest
index 341e1a745767..b161626624b5 100644
--- a/dev-python/cmd2/Manifest
+++ b/dev-python/cmd2/Manifest
@@ -1,3 +1,5 @@
DIST cmd2-2.5.7.tar.gz 691584 BLAKE2B a43f22817cd028913d1ec49150d826e33ddde1037c2cd1bce066d9ee85c20e5f59daa1b7d5365968aa7f17e3709bd7a58e586c449415ea93f62b157df08eb366 SHA512 b230b7fbad97bdba28a1335839e13c711ef629b0c18c1773c24c64a34626217659e1c362e8d72d71726baa06c50ba3f89732860eee8e527d1485de17e0eeacb7
+DIST cmd2-2.5.8.tar.gz 592395 BLAKE2B 52ea8ffd83dc8fdc904bba8b0bc72960d3782d0bf43a7dcb99b00d68f5bc4fcb5d17ddbe44655cb812bceed861a0dfd8d8753d818233dd9b1ad0e4461ce29eff SHA512 ce19006dff46279f14ac7d23ab4177b7926b061565ceff054291a508773ed0c037bdd20ffc72ecc99d44bcbc3751a486a14dd9d1d43c2e61a7ebd45cf967f06c
EBUILD cmd2-2.5.7.ebuild 1327 BLAKE2B 0f877689c5e9a87cebd301564a65cbae8e817ed13562053491b58842da1b7480e3500cb8f7cddc600d3df1f2a6ff9a27a8aedb521d162201f38da0c98e9f3d6b SHA512 8b3d7e4c6e41cd4b60112a0bbc12f849c7bf8f718754030b0d8e1d4bcf2c7ca9a3a0c58239a4979bc2c74a8ccde07003bfb9f68bba4490f199ea698754bd4f68
+EBUILD cmd2-2.5.8.ebuild 1332 BLAKE2B b0d912a7d7d35e4148d4932635c8348fcd9b10ccb46a9758754c68d764aacf17789bf34ebfb3e30416cbdf870d512e64a0cb2a519188dca5c366b92611bf0fd3 SHA512 1a3c84a81e73d8bee162bb5f88b03034d9c3be4d1bf767bcada796dee1a94c501cd2ac189ee4dfc8f516eb35ae85fce4f7a32737184d87996690f28f5ea9850b
MISC metadata.xml 522 BLAKE2B 39d319b6a64a7b54568a3fbd3d7db9adf7719b690a8f086018ce41f0595db157b1f7825ce28afb4fb0d748ca0d6dc21d79e480361b69b4bf29c0efc2d2540bba SHA512 57315c23dd64534085502e59f0b8ca01ef8088d5a2b16ed807631a1f36a523768960754b00619e802333552c405e2984e314d91003f7a624da6f1eb8e8e4b98a
diff --git a/dev-python/cmd2/cmd2-2.5.8.ebuild b/dev-python/cmd2/cmd2-2.5.8.ebuild
new file mode 100644
index 000000000000..820c48bb0ffa
--- /dev/null
+++ b/dev-python/cmd2/cmd2-2.5.8.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 virtualx pypi
+
+DESCRIPTION="Extra features for standard library's cmd module"
+HOMEPAGE="
+ https://github.com/python-cmd2/cmd2/
+ https://pypi.org/project/cmd2/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/pyperclip[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+# pyperclip uses clipboard backends in the following preference order:
+# pygtk, xclip, xsel, klipper, qtpy, pyqt5, pyqt4.
+# klipper is known to be broken in Xvfb, and therefore causes test
+# failures. to avoid them, we must ensure that one of the backends
+# preferred to it is available (i.e. xclip or xsel).
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ || (
+ x11-misc/xclip
+ x11-misc/xsel
+ )
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ # tests rely on very specific text wrapping...
+ local -x COLUMNS=80
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # TODO: tests_isolated?
+ epytest -o addopts= -p pytest_mock tests || die
+}