summaryrefslogtreecommitdiff
path: root/dev-python/cliff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cliff')
-rw-r--r--dev-python/cliff/Manifest2
-rw-r--r--dev-python/cliff/cliff-4.0.0.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/cliff/Manifest b/dev-python/cliff/Manifest
index ce418fa61f78..ccc0ef1ac820 100644
--- a/dev-python/cliff/Manifest
+++ b/dev-python/cliff/Manifest
@@ -1,3 +1,5 @@
DIST cliff-3.10.1.tar.gz 82764 BLAKE2B 88e8481d23f6ad35acac9fd17b1e4930f31ebc13211ad5bf1db441dbe4ad99faec023b6a46640d0fa3dbac4d76f4fd9d9fd3cd1e6c319cab390d502c9adff53c SHA512 2a1eb1f5311eb92ac481b35e0f703bb37171c9c7eee68a3d8322786a802d562d990ea8e3e52e924215b2ff8c3f14614f99ea403d94bfa2ea3794ab3556baa0c9
+DIST cliff-4.0.0.tar.gz 82758 BLAKE2B 47bc6d15426208c35582e852b7c52620b4fde292f2cc8bba1ba18ca01ef0cb3eda442ec406d2da7abb525fd659e055d08fa64c390a2274a8eea714489435957d SHA512 2886c2697c81c640cd3909c7e00fa50b0e39ed3824c8594d45af30e876cbfa73161be35c668c9bf964a5716bbb2b6e0cfef69526346e1d35156b5dbc24a7dc06
EBUILD cliff-3.10.1.ebuild 1112 BLAKE2B 33776b3ea7488e5ea45d47eace9b5e58cb0d3e0431e7f4fc7f1f4d38f8b4acdb431110faad821dc9c3ce007e8310600311a9d34cdb5c984b61f69b71ff9b0ed1 SHA512 3759a0e561ca2ca0dc1e777d7338a0f9160c17ea127f65bdb01fbc2d9c80d8c4fa8994a4884ec6b8b215806954e4bd5f2480d4ac750f76405e470669b5ecd413
+EBUILD cliff-4.0.0.ebuild 1171 BLAKE2B 2a1a8b33053d5dc861fb8668fc8d099d95478f056ba5aaffb445d1f01879791220cb6c62853c4db5238529c7e24f1997f8975ebb8824af5192108da760f8d757 SHA512 c355ee124cf3ebc71028c2b0bf4a896c8d2c2aafb3c162ce8953f333272a28ee816cab5e83b51f77a2e01388382cf4be9c4d29de068b52410ea453d2503fc5f8
MISC metadata.xml 767 BLAKE2B d9d994960046172167f20f59073011b2defe84e94144386db5465a973050e48e05abccff88d7f84cbe9f20615eddc5b61a46920f8b27c4dc9b2587f762f3e368 SHA512 018a0bfac3f0126341207d16203fab4a666b17d8a5dcf9f101335c396797f2e724e2250910fca39e12cb6616614983a756a42dac03aa215d2a1b51af5246269b
diff --git a/dev-python/cliff/cliff-4.0.0.ebuild b/dev-python/cliff/cliff-4.0.0.ebuild
new file mode 100644
index 000000000000..8bf1ddb73cae
--- /dev/null
+++ b/dev-python/cliff/cliff-4.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Command Line Interface Formulation Framework"
+HOMEPAGE="
+ https://opendev.org/openstack/cliff/
+ https://github.com/openstack/cliff/
+ https://pypi.org/project/cliff/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/autopage-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/cmd2-0.8.0[${PYTHON_USEDEP}]
+ dev-python/prettytable[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-4.11.1[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest