summaryrefslogtreecommitdiff
path: root/dev-python/cliff/cliff-3.6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cliff/cliff-3.6.0.ebuild')
-rw-r--r--dev-python/cliff/cliff-3.6.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/cliff/cliff-3.6.0.ebuild b/dev-python/cliff/cliff-3.6.0.ebuild
new file mode 100644
index 000000000000..a3bff2da3f73
--- /dev/null
+++ b/dev-python/cliff/cliff-3.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+# TODO: revert to rdepend once this is merged
+# https://github.com/openstack/cliff/pull/3
+DISTUTILS_USE_SETUPTOOLS=manual
+
+inherit distutils-r1
+
+DESCRIPTION="Command Line Interface Formulation Framework"
+HOMEPAGE="https://github.com/openstack/cliff"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/cmd2-0.8.0[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest