summaryrefslogtreecommitdiff
path: root/dev-python/cliff-tablib
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cliff-tablib')
-rw-r--r--dev-python/cliff-tablib/Manifest1
-rw-r--r--dev-python/cliff-tablib/cliff-tablib-1.1-r1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/cliff-tablib/Manifest b/dev-python/cliff-tablib/Manifest
index febef2587255..0c97787ea6d1 100644
--- a/dev-python/cliff-tablib/Manifest
+++ b/dev-python/cliff-tablib/Manifest
@@ -1,3 +1,4 @@
DIST cliff-tablib-1.1.tar.gz 80508 BLAKE2B 11faebcfd01813467850f17f49d9ef18f6d15b8a9d13b58b2a36e115ef17913b8f21cb19709f9938e8cdded2538b5c3affbe548896cbd95f0957eda4f5fb8a71 SHA512 26beea20ca1ba5c96276ce974c24bab572c6efebfe44ef45bd3ee6197593a34bf29843676a4e37fe400272f3ff59f703d60ff1abda22a1ca28c2434c0f224aac
+EBUILD cliff-tablib-1.1-r1.ebuild 786 BLAKE2B ce3f74c1d6d5f87f850f968473fe5c3951e6082cf70cfe1ecaa22035d1db7cde69fd04506941afc98bf8d17296857bdd82ec61706f490066658e219aab8f68c3 SHA512 225e0e5b93a7599717e4428ef9059151173b5ddabd884229f98136821c1c54133c17659f1cfa5ef2366c78cd2c5a11444b7d3fe0a105294e9ac217e5d8a4174e
EBUILD cliff-tablib-1.1.ebuild 783 BLAKE2B 15f1ca9519d7817edf7f0678d44f80ee420b4f06fe0c8ae874814553b3dcb44620595fbdeb3f9237f71a3a079f072d35c0a36f6e9cb40c892b42cce317e001eb SHA512 a5a9944931fa2e4b11aa06c8661d4ef35c6c064c41d32b41d9526678bd7182c4e31f73412b9727cdd64ea6853c4e1196c7bf239e0c7588ee27b6d6d14b3c5235
MISC metadata.xml 395 BLAKE2B 875c5346b128d3653e234932bdf62471ad993980ad77006296bc6ad3710fb71089df8c375b42d5f5e219f433dfafe67a389b0a2a04a2f99db0537f89f496bbc1 SHA512 874e5cc1c3b1c7341127ab43fde400a9341d9475f6c32f44b3f0faedd8e422324d703eaa814b9cbb4a5fe0ac13a09320c60f83f236cd51bd6247def77005e71e
diff --git a/dev-python/cliff-tablib/cliff-tablib-1.1-r1.ebuild b/dev-python/cliff-tablib/cliff-tablib-1.1-r1.ebuild
new file mode 100644
index 000000000000..47cfc031561a
--- /dev/null
+++ b/dev-python/cliff-tablib/cliff-tablib-1.1-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Formatter extensions of JSON, YAML, and HTML output for the cliff framework"
+HOMEPAGE="https://github.com/dreamhost/cliff-tablib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="amd64 ~x86"
+IUSE="doc examples"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="dev-python/tablib[${PYTHON_USEDEP}]
+ dev-python/cliff[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ # Use IUSE examples for installing the demoapp
+ use examples && local EXAMPLES=( demoapp/. )
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}